Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having a bit of Internet trouble with a fresh install of Ubuntu Natty and I haven't been able to track down the problem. I have my desktop running over a wireless network, which connects without fail. Somewhat frequently, however, connections to particular websites will start timing out (google, facebook, stackoverflow, us ubuntu archive, etc.). I'm also having a strange issue where my home page (www.monkeymadestudios.com) is redirecting to www.monkeymadestudios.com/cgi-sys/defaultwebpage.cgi.

Initially I thought it might be an issue with Comcast DNS, so I updated the router to use OpenDns servers. When that didn't work I started to try accessing some of the problematic sites through my laptop (which is using the same router) and they all connect without problem.

The issue seems to be with my Ubuntu install, but I'm not sure where to look. Any pointers would be great.

EDIT After doing some further digging, this is starting to look like a DNS issue. My home page appears the resolve to an incorrect ip address when the redirect issue occurs. Still not sure how to track down the problem, however.

share|improve this question
    
They do ping, right? –  new123456 Aug 28 '11 at 20:04
    
It appears they are not pinging when the issue occurs. Not from my desktop at least (laptop works/pings fine). Any ideas there? –  Jason George Aug 29 '11 at 3:47
add comment

1 Answer

up vote 0 down vote accepted

After beating my head against this for several days I think I've finally found the secret sauce.

Originally I was getting my DNS settings from my router (configured to use OpenDNS rather than my ISPs--208.67.222.222 and 208.67.220.220).

This is the result in /etc/resovl.conf

# Generated by NetworkManager
domain Belkin
search Belkin
nameserver 192.168.2.1
nameserver 208.67.222.222
nameserver 208.67.220.220

I'm not sure if this is correct, or typical, but I decided to cut the router out of the loop altogether. I changed my IPV4 settings for my network interface from Automatic (DHCP) to Automatic (DHCP) addresses only and set my DNS servers to 208.67.222.222, 208.67.220.220

After restarting the computer, this is what I get in /etc/resolv.conf (NOTE: disabling and re-enabling the interface also updated resolv.conf, but did not resolve the problem)

# Generated by NetworkManager
nameserver 208.67.222.222
nameserver 208.67.220.220

With the restart, everything seems to work fine now.

Just to verify, I reset my network interface to Automatic (DHCP) and cycled it (disabled/enabled). My DNS issues immediately restarted. A second loop through the procedure has everything working again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.