Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed the TweakNow PowerPack 2011 for Windows 7, and I ran it and applied the suggested optimizations. Soon after that I began getting Windows messages saying that my system was low on memory and programs (Chrome and Steam) started crashing. I have owned this computer for over a year and this has never happened with the exact same set of programs (or more) running. I don't know what I changed to cause this, but I checked that the RAM optimizer is disabled. What should I do to fix this problem?

EDIT: I cannot reproduce the problem anymore, so I will post an answer with what I think the solution was when I can. (In other words, I cannot judge if an answer is correct).

share|improve this question
    
Can you undo the tweak settings? –  Moab Aug 28 '11 at 17:17

2 Answers 2

On Windows 7 you can use the System Restore functionality to restore your system to a state before you made the changes.

You should simply be able to press the "Windows" button (or "Start" button if you prefer to call it that) type "system restore" select the program that appears at the top of the list.

In that program you should be able to select at date before you made these changes and your system will return to the way it was before the changes were made.

-=EDIT=-

As you lack the ability to use System Restore, I am afraid you are a bit more limited.

Most tweak tool programs I've seen have a option to "restore" the changes that they made, it's usually hidden somewhere in the options.

If possible you will want to undo the work of the Registry "Cleaner" as the first port of call, those things usually do more harm than good in my experience. Often when you do a clean they will ask you where you want to store the backup ".reg" file and if it did, and you saved it, it should be a simple matter of just finding and double clicking that .reg file to revert the cleanup.

As to the low memory warnings, you can check that your page file is enabled (follow the guide on this page, except you want to let Windows automatically manage the size) as it is possible that one of the tweaks may have disabled it for you.

share|improve this answer
    
This looks like a good solution, but I do not have any restore points (apparently automatically creating them is off by default) –  murgatroid99 Aug 28 '11 at 17:38
    
It should not be off by default in W7, something turned it off. –  Moab Aug 28 '11 at 18:20

It appears that the problem was solved by closing and disabling the RAM Optimizer and then rebooting the computer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.