Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have attached a VHD inside windows 7 and gone into disk managementt. When I right click on the drive which currently states it being as deallocated, the option to initialize the disk is greyed out. Does any one know why this would be and how I can solve it?

Andrew

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Have you tried to close and re-open disk management? The only other reason could be that you don't have enough permission to the VHD file, or alternatively that there is an error with the VHD.

Try creating a new blank one and see if this error persists.

share|improve this answer
    
I think it was the pernissions as you say as I added my self with full control and hey presto, you basically saved my day:-) Cheers Diago!! –  REA_ANDREW Aug 31 '09 at 14:08
add comment

I experienced exactly the same behavior. In the end it turned out the reason was that Windows cannot attach a VHD from 4K-sector disks. Not kidding. Even though the same machine (Windows Server 2008 R2) had written those VHDs on this disk using Windows Server Backup. 4k sector support is only available for Windows Server 2012/Win8 and VHDX.

The page gives some more details: http://gadgets.itwriting.com/998-why-your-new-2tb-or-3tb-drive-will-not-work-with-windows-backup.html

In my case, Windows Server Backup still worked: I was able to do a selective restore of some folders using the Recover option.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.