Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed W7 Ultimate, successfully relocated my User folders to second partition (D) and copied all documents, music, videos etc from old hard drive (which used to be labelled D in Vista).

iTunes used to be located at D:\CeeJay\Music, so is now located at D:\Ceejay\My Music - and therefore cannot link library entries to iTunes Music Folders because of differing filepath.

'Right', I thought, "Let's create a folder called D:\CeeJay\Music as well, and move iTunes to that so its filepaths match exactly."

Good idea - but doesn't work in practice because Windows 7 sees D:/Ceejay/Music as the same name as C:/Ceejay/My Music and wants to merge the two folders when I try to create D:/Ceejay/Music.

Any ideas?

share|improve this question

2 Answers 2

All that needs to be changed, is the location of where iTunes looks. It's quite simple. Follow the steps below.

Change the Location iTunes Folder

  1. Open iTunes
  2. Click on Edit on the top menu bar
  3. Click Preferences
  4. Click the Advanced icon/tab
  5. Click the Change... button
  6. Locate your iTunes folder (See Note)
  7. Click Select Folder with the iTunes selected
  8. Click OK
  9. Let iTunes update its database
  10. Restart iTunes to confirm

Note: Do not used the iTunes Media folder. Use the iTunes folder instead. Steps are in detail to help both experienced and non-experienced users.

share|improve this answer

The reason you are getting the error is because what you actually have is a folder called "Music" which is a special folder in Windows which displays the name as "My Music". If you were to view this folder from another user on your machine you would see it as "Ceejay's Music" or whatever you username is.

Within the "My Music" folder you are seeing there will be a hidden system file named desktop.ini and it is this file that tells Windows about the folder.

If iTunes is not stupid you should be able manually edit the path that it is looking at to remove the "My" from the path it gets as D:\CeeJay\My Music (so it looks like D:\CeeJay\Music in the text box) and it should simply work as normal as the paths are equivalent.

I've tried looking for a way to change the name of the "My Music" folder to simply be "Music" but I can't find anything.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.