Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm planning to move to ubuntu from windows, but I don't know how to configure VPN in ubuntu.

On windows, the VPN provider has provided a GUI application, I just need to input my username and password, then choose a server in a list, everything is done.

But I input the same information into ubuntu, in the following dialog:

vpn-dialog

But it can't connect to server, the error message is:

vpn-error

(PS: I'm running the ubuntu in Virual-Box with default settings, and the type should be PPTP)

How to configure it correctly?

share|improve this question
1  
First, find out the VPN type. Cisco? OpenVPN? PPTP? IPsec? –  grawity Aug 29 '11 at 13:25
    
Thank you. It's PPTP –  Freewind Aug 29 '11 at 13:37

2 Answers 2

up vote 1 down vote accepted

Without knowing the exact specifics of your VPN server, I can't really say for sure.

However, if it is a Windows VPN server you are connecting to (PPTP) I wrote a blog post about it... Click Here to read

Basically, go to your Windows box and try to copy all the settings you can find, in particular the security/encryption details.

If you are using a Windows VPN, here are the pictures from my blog post on how I set up Ubuntu to connect to my VPN server:

enter image description here

share|improve this answer
    
Thank you, but unfortunately, it doesn't work for me, still can't connect. Do you know how to see the detailed log? –  Freewind Aug 29 '11 at 14:09
    
@Freewind Do you have access to the VPN server? –  William Hilsum Aug 29 '11 at 14:14
    
Check your logs - sometimes you'll get more information from them about what the failure is. –  Broam Aug 29 '11 at 14:20
    
@Broam, I'm not familiar with ubuntu, could you tell me how to check the logs? Where is the log file? –  Freewind Aug 29 '11 at 14:33
    
System -> Administration -> Log File Viewer if you want graphical. If you want to browse the files yourself, check /var/log –  Broam Aug 29 '11 at 17:03

You might want to try ensuring that "Allow Stateful Encryption" is checked (in addition to the above screenshot settings)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.