Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a file named foobarë. When I try to 7zip it on Debian (stable) via Putty, I get the following:

server:/tmp#  7za a test.7zip foobarë

7-Zip (A) 9.04 beta  Copyright (c) 1999-2009 Igor Pavlov  2009-05-30
p7zip Version 9.04 (locale=en_US.UTF-8,Utf16=on,HugeFiles=on,1 CPU)
Scanning


foobarë:  WARNING: No more files


Creating archive test.7zip



WARNINGS for files:

foobarë : No more files
----------------
WARNING: Cannot find 1 file

Somewhere along the way the foobarë is converted to foobarë. How can I fix this?

My locale on Debian (at least, the content of /etc/locale.gen and locale -a) is en_US.UTF-8 UTF-8.

share|improve this question
1  
This forum post may be of interest to you. –  digitxp Aug 29 '11 at 18:51
add comment

3 Answers

up vote 2 down vote accepted

Make sure PuTTY is in UTF-8 mode. Go to Window → Translation, under Remote character set choose UTF-8. Go back to Session, select Default Settings and click Save.

share|improve this answer
add comment

It may be that the version of 7-Zip you are using is an old version and if I remember correcly around the 9.04 area there were two versions of 7-zip, one which used the standard character set and another that was Unicode.

The current version of 7-zip is 9.20, yours appears to be 9.04. Can you update and try again?

There is also a bug report from the p7zip (Unix port of 7-zip) Sourceforge page that claims this was fixed since 9.13, so again I would recommend updating to 9.20 if possible: Sourceforge Bugtracker

share|improve this answer
add comment

The answer might also be in Putty... Putty itself (Window->Translation) wasn't set to UTF-8. I've switchted to UTF-8 now, my foobarë file now has a weird name, when I make it again it 7zips correctly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.