Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Windows 7 on my laptop. When I shut it down it told me it was updating the system and not to power off. However I was feeling sleepy so I just powered it off forcefully.

When I started it up in the morning it prompting me with this error:

Fatal error c0000034 applying update operation 202 of 115450(prog..)

Can anyone suggest how can I solve this issue with my laptop? Do I have to reinstall Windows again?

share|improve this question

migrated from stackoverflow.com Aug 30 '11 at 8:29

This question came from our site for professional and enthusiast programmers.

3  
Sigh. A sign says, "Danger, don't jump off the cliff" but you do it anyways. I sympathize with what Microsoft has to take into account. . . –  surfasb Aug 30 '11 at 8:55

3 Answers 3

It's unlikely you can roll back that update. Especially since it bluescreens on boot. If you do manage to boot it up, there is no telling what else is corrupted. Save yourself some time and reinstall.

For future reference, if you are in the middle of an update and you have to shut off the computer, select shutdown from the start menu.

Windows will log you off and continue to finish the updates. Once it is done, Windows will complete the shutdown automatically.

edit

Follow the steps here to get you out of the reboot loop.

http://community.spiceworks.com/how_to/show/2019

It should get you into the OS. But you lose any changes that could be rolled back and it leaves your OS in a state of purgatory. There is no telling what may or may not be corrupt and I highly advise you think about backing up your data.

share|improve this answer
    
So i need to reinstall OS..is it the case or if u have any other way to recover ..pls let me know thanks. –  Shubh Aug 30 '11 at 9:28
    
You can try the steps to roll back the update here. It should at least get you into the OS and start backing up your data. Whether your OS is still solid isn't guarenteed. –  surfasb Aug 30 '11 at 9:37

Have you tried booting to a Windows 7 disk and seeing if the tools provided can repair the system? Specifically, you can try to roll back to a System Restore point to before the installation started.

If you don't have a Win7 disk available you might get lucky and be able to boot in to safe mode (press F8 after the POST screens but before Windows starts to boot) and try there, but if you're bluescreening then safe mode may fail too.

In theory, restoring to a previous SR point should put the computer in to the state it was previously - so the update will never have started.

share|improve this answer
    
totally wrong happened...i lost my total data...it's totally worst case ever of my life.I lost all my programming/coceptual all all everything...ohhh –  Shubh Aug 30 '11 at 17:02
    
What, from rolling back to a system restore point? Is Windows still failing to boot? –  DMA57361 Aug 30 '11 at 17:10
    
no i just tried to repair my system...but it showing some other error ...and now when i tried to again repair it..showing disk totally blank.. :( –  Shubh Aug 30 '11 at 19:07

Use F8 at the Bios splash screen to get the Windows Advanced Menu, then select "Repair your Computer" from the list, Windows RE will load, when you get the WinRE screen, choose "repair your Computer" again, Now the tools will load, if you get a popup before the tools load asking to repair, say NO, then run Microsoft System Restore, pick a date before you ignored the message.

.

enter image description here

.

enter image description here

.

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.