Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How resolve this issue with dxgi.dll? I originally thought issue was related to Desktop Window Manager (dwm.exe). However, after trying run a System File Check, I got similar error related to dxgi.dll. I know the issue is related to this file. How do I fix this issue? I tried replacing the DLL file from one found online. However, system32 folder locks up, in both normal start up and safe mode, when searching for dxgi.dll in the folder or scrolling down to it and clicking on it.

What I know or have already tried:

  • Error in both Safe Mode & Normal Start Up upon login
  • Restored to a 3-day old Restore Point
  • Last install was iTunes 3 days before the issue begin
  • No changes were made in the past week or longer
  • Reinstalled DirectX
  • No other graphic or display issues
  • Ran Full Virus Scan via Norton Internet Security
  • Uninstalled and Installed the latest GeForce 460M drivers
  • Windows is completely updated
  • Ran System File Check but failed at 11% (Normal & Safe Mode) - See Screenshot

Screenshots:

Error: dwm.exe - Bad Image
Error when running System File Check.

Error: dwm.exe - Bad Image
Original error on start up.

share|improve this question
    
Does this happen if you boot in Safe Mode? –  Dave M Aug 30 '11 at 21:12
    
Try reinstalling/updating directx. –  MaQleod Aug 30 '11 at 21:38
    
Yes it happens in Safe Mode too. –  SgtOJ Aug 30 '11 at 22:21
    
This isn't a virus. It's probably a driver issue, so it'll be interesting to hear what happens when you've updated the video driver. –  user3463 Aug 31 '11 at 6:59
    
Took longer than expected to update my question. Internet service in Afghanistan isn't the greatest. Thank you for your patience. –  SgtOJ Sep 2 '11 at 4:29

1 Answer 1

up vote 1 down vote accepted

After trying all the troubleshooting steps in my question, I decided to do a fresh install. A restore from a backup image would have worked too.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.