Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to use Windows 7's backup and restore utility to schedule the creation of a system image of 3 partitions (C:, D: and E: drives).

When I configure the backup utility, I choose the option that allows me to control what to backup, uncheck all the 'Data Files' and 'Computer' options, and check the option that says 'Include a system image of drives:...'; but the D: drive is not listed there (and it's not backed up).

Is there any way to force Windows to include the D: drive in the System image created during backup?

share|improve this question
    
I can't understand your question. Please re-read it, and correct any grammatical mistakes you might have. –  wizlog Aug 30 '11 at 21:53
    
As far as I know Windows System Image backup does not allow for you to exclude files, you must be using File and Folder backup? –  Moab Aug 30 '11 at 23:10
    
If you don't select any files to do backup, but select to include a system image, the backup creates a system image, my problem is that is leaving a partition out. –  Pablo Montilla Aug 31 '11 at 12:17

2 Answers 2

If you want to backup multiple partitions, you'll need to choose the drives under computer on top of "include a system image."

edit

Looks like you have to hit up the command line to image data volumes.

Use the following command.

wbadmin start backup -backuptarget:targetpath -include:c:,d:,e: -quiet

Add that to Task Scheduler and you should be good to go.

note

Windows does not do multiple image versions on network shares (no clue why). An easy solution is to just create a batchfile that cycles through n directories for you backups. You would have to setup the directories first.

@echo off

set backupdir = path to backup directories

for /f "usebackq delims=" %%I in ('dir "%backupdir%" /b /ad /o-d`) do (wbadmin start >backup -backuptarget:"%%~fI" -include:c:,d:,e: -quiet)

You could also create n tasks in Task Scheduler and have them run daily. Then change the daily setting from every 1 day to n days. That's probably a more complicated way.

share|improve this answer
    
That option exists but only works if I do it manually. I want my scheduled backup to include the D: partition that is left out. –  Pablo Montilla Aug 31 '11 at 12:19
    
Ahh, true. Didn't realize the scheduled backup does not include imaging data partitions. You'll have to hit up the command line. I'll edit my answer. –  surfasb Aug 31 '11 at 14:13
up vote 1 down vote accepted

After various unsuccessful attempts at solving the problem, I stumbled upon the solution while looking at a Microsoft forum (sorry, don't remember the URL).

It appears that the criteria that's used for marking a drive as Critical, and therefore marking it for backup when asking for a scheduled system image, includes the presence of a Service with files in the given drive.

So it is possible to force windows backup to create a system image of drive by issuing this command:

set drive=D
sc create DummySvc%drive% binPath= %drive%:\Dummy.exe start= disabled DisplayName= "Dummy For Backup (%drive%:)"

Which creates a dummy service that's disabled, but refers to a file in the target drive. This will force Windows Backup to include it, solving my original problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.