Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The question describes well what I need but here are some more details about the circumstances.

With Parallels Desktop 4 running under Linux, I have a number of Windows 7 Virtual Machines. Sadly, Parallels has not been upgraded for a while, so I am trying some other VMS and VirtualBox was highly recommended. Particularly, it is provided with the OpenSUSE Linux distribution. This will avoid the problem and allow me to keep up to date with the latest OpenSUSE.

So my question is, how can I convert a Parallels VM into a Virtual Box one?

share|improve this question
up vote 7 down vote accepted

VirtualBox can use Parallels (.hdd) disks in simple-format without conversion. If the disk does not use the simple format, it must be converted first using the Parallels Image Tool.

But I would uninstall Parallels Tools first (if you have it installed on the VM) and make a backup copy of the VM. Then create a new VirtualBox machine, matching the CPU and memory settings as closely as you can to the Parallels machine.

You may also refer to this article on migration, although it is a bit old and recommends using VMWare Converter, which I would avoid if you can.

share|improve this answer
It seems to be looking for .vhd, ,vdi or ,vmdk files... which my Parallels VM does not have. Do I need to rename something? I've got an empty .hdd file and .xml file in the directory of the VM. – Itai Aug 31 '11 at 17:16
What version of VirtualBox are you using? And what version of OpenSUSE? It looks like Parallels disk support was added in 3.1.0. – seisyll Aug 31 '11 at 17:22
VirtualBox is 3.0.6 and OpenSUSE is 11.2. I've been trapped at 11.2 because of Parallels. – Itai Aug 31 '11 at 17:38
Getting closer, updated VirtualBox to which now sees the .hdd file but gives an error: NS_ERROR_FAILURE (0x80004005) - I tried with the VM not running and running, same error. – Itai Aug 31 '11 at 17:56
I would guess that the disk is a newer Parallels disks (version 3 or 4). Try converting it down to version 2 disk and have another go. Sorry for the goose chase! – seisyll Aug 31 '11 at 20:39

Not sure how this will go, but you could try this guide I found that uses the VMware Converter.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .