Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a HP EliteBook 8540w with an Nvidia Quadro FX 1800M video card. Every time I unplug an external monitor or the power, it gets a Blue Screen of Death. Are there some drivers I should update? Is this just a manufacturing defect?

share|improve this question
2  
What does the blue screen say? –  MaQleod Aug 31 '11 at 17:14
    
Don't know it's up for about 1 second then the computer restarts. –  norlando Aug 31 '11 at 18:57
1  
To get Windows to not reboot on blue screens so you have time to take a look, go to Control Panel, change "View By" to icons, then go to System -> Advanced System Settings, click on "Settings..." in the Startup and Recovery section, then uncheck the box under "System Failure" that says "Automatically Restart". –  rakslice Sep 1 '11 at 18:14

2 Answers 2

up vote 1 down vote accepted
  1. Reinstall the chipset drivers.

  2. Reinstall the graphics driver; if the Nvidia site doesn't give a recent driver, try Laptop Video 2 Go.

  3. Check your event log for warnings/errors that could you help troubleshoot further.

  4. A BSOD usually leaves a dump to check, look for files in %SYSTEMROOT%\Minidump or look for a for MEMORY.DMP in %SYSTEMROOT%. You can compress the file with a progarm like 7-Zip and upload it, or you could use WinDBG from the Debugging Tools for Windows to debug it yourself (in which case you need to open it, click or enter !analyze -v and try to make sense of the outpt).

    It would mention the most likely driver that caused the problem; well, if it was a driver...

share|improve this answer
1  
Looks like it was driver related. –  norlando Sep 1 '11 at 20:01

Try following the steps described in the following blog post:

Issues with NVIDIA drivers on HP 8540w - The Plexus - Site Home - MSDN Blogs

  • Before you install the drivers, go to power options and click on “Change plan settings” on any power plan
  • Click on “Change advanced power settings”
  • For each power option (in the dropdown list) disable the “Link State Power Management” options (on battery and plugged in) under PCI Express – make sure you change this for all power options in the dropdown list (balanced, high performance, power saver and any others that are available)
  • Install the latest NVIDIA Drivers
  • After installing the drivers and before rebooting, for each power option disable the “NVIDIA Display Power Saving technology” under Display for both “On battery” and “Plugged in” options – make sure you change this for all power options in the dropdown list (balanced, high performance, power saver and any others that are available)
  • Reboot and enjoy
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.