Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Recently, the French keyboard layout added itself to my computer spontaneously. When I cycle through the languages with Left Alt+Shift as I normally do, I get French between English and Hebrew. It even shows up on the language bar near the tray. However, it doesn't appear on the list of keyboard layouts in the Control Panel, so I can't delete it.

Can anyone please direct me to the relevant registry value so I can get rid of this unwanted layout manually, or perhaps offer an alternative solution?

share|improve this question
up vote 3 down vote accepted

Start>Control Panel > Region and Language > Keyboards and Languages tab> Change keyboards> click on the one you want to remove, and click remove. Then click OK, and your done!

EDIT: if the answer below mine doesn't work, then I'd try installing then uninstalling it.

share|improve this answer
1  
If it only was that simple... – Tom Wijsman Aug 31 '11 at 17:30
1  
As Tom stated, it isn't that simple... It doesn't appear there. – Al G Aug 31 '11 at 17:44
    
O... Does Tom's answer work? or do you still need an answer. – wizlog Aug 31 '11 at 17:48
1  
I've just managed to solve it on my own, coincidentally by applying the solution you edited in, which unfortunately I didn't notice until coming back to update here :) – Al G Aug 31 '11 at 18:00

This question has been asked and answered multiple times, however no solution worked for me.

Solutions in escalating complexity:

  1. Click the language in the language bar, select "Language preferences", select the rogue language, click "Remove". If the language is not present in the list, go to step 2.
  2. Click the language in the language bar, select "Language preferences", select "Add a language", find it in the list and add it (make sure to select the correct sub-category for your rogue layout), select it in the list of languages, hit "Remove". The language should now be gone. If it returns at a later date, go to step 3.
  3. Regedit time. (Editing your computer's registry can have unintended consequences and can lead to system instability. Please only do this if you are sure you know how the registry works.) Open the start menu, search for "regedit" and run regedit.exe, navigate to "HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/Keyboard Layout", making sure not to confuse it with "Keyboard Layouts". Right click in the right panel, select New > DWORD, name it "IgnoreRemoteKeyboardLayout", double click it and set the value to 1. Close regedit, remove the rogue keyboard manually (using steps 1 or 2) and restart your computer. This should fix 99% of problems with rogue keyboard layouts. (Source) If it however returns, go to step 4.
  4. Hopefully your problems will have been fixed before you got to this step, as it's merely a mitigation, not a solution. If none of the previous steps worked, then start regedit again, navigate to "HKEY_USERS/.DEFAULT/Keyboard Layout/Preload", look at the values of the attributes here. They should be enumerated 1, 2, 3, ... and they correspond to the currently active keyboard layouts. note down the values (for example 00000424 and 00000409). Now navigate to "HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/Keyboard Layouts" and expand it. You will see many folders. Find the ones with the same numbers as the ones you just wrote down. For each of them, select it in the tree on the left and look at the "Layout Text" property. Using this, identify BOTH the rogue keyboard layout and your preferred keyboard layout. If you cannot find the rogue one, then manually add it like in step 2, look at the "Preload" folder again to find the new entry and then find that in the expanded Keyboard Layouts folder. Please note that deleting the keyboard layouts folder of the rogue keyboard won't work, it will be restored. Once you have identified the folders for your preferred and rogue keyboard layouts, look at the "Layouts File" property for your preferred one. Copy its value and paste it into the rogue keyboard layout's "Layouts File" property. Once you have done this, turn close regedit, remove the rogue keyboard again like in steps 1 or 2 and restart your computer. From this point on if the rogue keyboard returns, it might say "English (United States)" or whatever, in the language bar, but it will behave exactly the same way as your preferred one. If you use two keyboard layouts and frequently switch between them, you might want to consider simply swallowing your pride and keeping the (modified) rogue keyboard. So, for example, if you routinely use Spanish and Italian, but English US often appears out of nowhere, you might edit English US to point to the Spanish keyboard layout and then remove the Spanish one.
share|improve this answer

Check the registry.

There might be something broken in the registry that is causing the Control Panel GUI to act weird.

  1. Open the registry editor and learn how to modify it, take a back-up if you are unsure.

  2. Find your keyboard lay-out in

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Keyboard Layouts
    

    using CTRL+F it seems that French is 0000040c, but your values might be different.

  3. Now, you need to remember that number (perhaps remember the ones you use too) and go to

    HKEY_CURRENT_USER\Keyboard Layout\Preload
    
  4. There, you need to make sure there is no value with 0000040c (which is French).

  5. Make sure the values are numbered from 1 to n where n is the amount of keyboard values.

    For example:

    1. If you only have US you would have a DWORD value 1 containing 00000409.

    2. If you also have French, you would also have a DWORD value 2 containing 0000040c.

    So, if you have 1, 2 and 3 and remove 2; don't forget to edit 3 to be 2.

Check the system locale.

In the Region and Language window, it might be interesting to check out the Administrative tab.

It contains some settings, especially the system locale for non-Unicode programs; that might interfere...

share|improve this answer
1  
Nope, only two values appear in \Preload - 409 for US, 40d for Hebrew. The system locale is also set to Hebrew. – Al G Aug 31 '11 at 17:46
    
@AlG: Odd, is this your own computer? Did you remember doing something with French before? Does it go after a reboot? If it doesn't get working, the only solution I see could be to create a new user profile, or set shortcuts to switch to a specific lay-out instead of toggling... – Tom Wijsman Aug 31 '11 at 17:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.