Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For some reason, whoever was on this computer before me set the default Google domain in Firefox to google.cz. I have tried going to the main page and clicking on the google.com link in the footer, but everything from the google.com domain throws a 404 error. How can I fix this?

share|improve this question

closed as not a real question by Bobby, ChrisF, Ƭᴇcʜιᴇ007, BBlake, KronoS Nov 5 '12 at 14:11

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
What steps have you taken to diagnose the issue? What do you mean by google.cz being the "default domain"? As is, this question doesn't give us much to go on. –  music2myear Aug 31 '11 at 19:29
    
You are able to set your google default domain to your countries domain such as google.com.uk and so forth. google.com wasn't working, and I couldn't figure out why, and I was looking in the history and google.cz was used previously, and that worked. It was in a different language and was able to change it. But I cannot go to google.com, I tried disabling proxy, I was told to go to the home page and click on google.com, and that brought up 404 error as well. –  Blake Aug 31 '11 at 19:33
    
By "the default Google domain", are you talking about a search engine in the Firefox Search Bar? If not, what Firefox setting are you talking about? –  JdeBP Aug 31 '11 at 21:01
    
Have you tried another browser? Does it work as expected there? –  Ƭᴇcʜιᴇ007 Sep 4 '11 at 4:22
    
I would guess that google.com is being blocked by the internet provider. –  Daniel R Hicks Aug 27 '12 at 21:16

2 Answers 2

Press CTRL-R to reload the page. You're probably just viewing a cached version of the page that you want.

Failing that, you can also try a different domain like http://www.google.ca/ and then click the option to switch to .com for your default.

share|improve this answer
    
I'm actually not even sure how to set the domain. I have searched around, and nothing actually shows how, just to click on the home footer link. –  Blake Aug 31 '11 at 19:41
    
@Blake: There should be a link at the bottom of the page named "Go to Google.com." –  Randolf Richardson Aug 31 '11 at 20:14

Have you deleted your browser cache? History and forms data does not need to be deleted, but cache and cookies should be at least.

Are there any other sites that are resulting in this behavior?

And where are you located? As in, what is your normal google domain?

share|improve this answer
    
yes, cache is deleted every time the browser is closed. only other google sites, such as google.ca come up with the 404 error I am located in america, not the czech republic, so google.com should be my default domain –  Blake Aug 31 '11 at 19:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.