Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My computer was infected with a virus. I scanned it with AVG and cleared it. It left me with a blank file that I cannot delete. When I right click on it, the only options I'm given are OpenHomePage, properties, Start without Add on and Create Short Cut.

The file has no name and no delete context menu option. I cannot move it to another folder. It does not show itself in cmd. I have no idea how to delete it. Here is what it looks like on my desktop:

icon for blank, unnamed file

[EDIT]

I tried Unlocker, but the blank file does not have "delete" or "unlock" options. I also tried booting to safe mode, but that did not give me a "delete" option either.

Again, the problem is that the file does not offer me an option to delete it. I can drag it to the Recycle Bin, but nothing happens when I do, not even a warning. I know it is related to some sort of virus/trojan. I tried running various antivirus programs including AVG, but the file still stays on the desktop. If I go to C:\Users\*someUser*\Desktop, the file is not there. It's only on the desktop as in the desktop of the computer screen.

[EDIT 2] In File Explorer, I see this:

blank file icon followed by "::{F986CC17-37C0-4585-B7D9-15F2161F0584}"

I searched for the key and found it in regedit. Should I delete it?

share|improve this question
1  
possible duplicate of How do I delete a 'locked' file? –  Nifle Sep 1 '11 at 12:25
1  
If none of the answers in that question works please edit your question to say so. –  Nifle Sep 1 '11 at 12:26
    
no, not duplicate. The file I have does not even allow me to delete as an option. No warming. No delete selection. I click "del" keyboard key, and not warming or effect. The process is stopping from delete it, the file just does not have delete as an option.. –  KMC Sep 1 '11 at 12:38
1  
Have you tried booting into Safe Mode and deleting it from there, or booting into a live ubuntu cd to remove the file? –  Sandeep Bansal Sep 1 '11 at 12:50
1  
What have you tried so far? –  Ƭᴇcʜιᴇ007 Sep 1 '11 at 13:05

2 Answers 2

up vote 3 down vote accepted

Not all items on Desktop are actual files – some of them, such as the standard "Recycle Bin" or "Computer", are added by shell extensions.

Since you already know the GUID, start with Registry Editor at HKLM\Software\Microsoft\Windows\CurrentVersion\Explorer (most probably Desktop\NameSpace, but possibly other subkeys). Regedit allows you to export keys, so you can experiment with each result: export to a file, delete, if it didn't help – import back again.

Note that the context menu options you listed are very similar to those of a built-in "Internet Explorer" desktop icon, so it could be that it became corrupted and should be recreated somehow. But, I would still say "delete it".

share|improve this answer
    
Thanks. After delete all the registry and restarting window. the file is gone. –  KMC Sep 1 '11 at 17:32
1  
"all the registry" ...? –  grawity Sep 1 '11 at 18:39

Just to add to this, I had the same issue with an unnamed file on my desktop that I couldn't remove or move. I determined the name by right mouse clicking and selecting "cut" and trying to paste it to another folder location. It gave the the name in the registry (similar to screenshot shown above in original question). I then found the numbers, and deleted it from registry with so far no bad effects. There was also a folder titled "Microsoft OneNote Namespace Extension for Windows Desktop Search" which wouldn't let me move or remove it as well, I did the same registry change to fix it. Seems like a possible windows 8 / office 2013 bug.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.