Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a date field in a Word document which was created from a template included with Microsoft Word 2010. The default setting for this field is to display only two places of the current year.

I would like to change it to display the complete year number. I found the "Date and Time" dialog as shown, but it doesn't include this formatting option (strangely, it neither includes the two-place year option).

How can I add a custom date format for this text field?

English Time/Date Settings

share|improve this question
    
What is your operating system? –  wizlog Sep 1 '11 at 15:01
    
+1 for trying to use a 4-digit year (everyone should be striving for this because 2-digit years can be particularly confusing now during the last 12 years). My favourite short date format is YYYY-Mmm-DD which, for today, shows as 2011-Sep-01, because there is absolutely no mistaking what each element means (although it is English-specific, so my second choice would be to use largest-to-smallest ordering {as is also done with time} in the numeric form of YYYY-MM-DD: 2011-09-01). –  Randolf Richardson Sep 1 '11 at 15:48
    
@wizlog: I'm on Windows Vista, but that has nothing to do with the Word-internal list of date formats. The mentioned "default setting" for the text field is specified in the template. I guess the easiest way to change the format is to unzip the docx file, find the XML source code specifying the textbox properties, editing those and zipping everything up again. Let's see. –  Felix Dombek Sep 1 '11 at 18:12
add comment

3 Answers 3

up vote 1 down vote accepted

Change the display of dates, times, currency, and measurements

This is also the method to changing the format Windows uses to display dates, times, currency, and measurements. You can also change the sorting order of text to match sorting rules used in a specific country or region.

Open Regional and Language Options by clicking the Start button , clicking Control Panel, clicking Clock, Language, and Region, and then clicking Regional and Language Options.

Click the Formats tab, click Customize this format, and then, click on date.

share|improve this answer
1  
This is a valid answer that resolves this issue for many programs (+1). Please don't delete it. –  Randolf Richardson Sep 1 '11 at 15:44
    
@randolf sorry, I had included something for 1995-97 version. I clicked delete, then undelete, then added this. I won't. –  wizlog Sep 1 '11 at 16:04
1  
Thanks for leaving it on -- you obviously put effort into posting a helpful answer, and I just didn't want to see your hard work wasted. Keep up the great work! =) –  Randolf Richardson Sep 1 '11 at 16:09
    
-1 This is absolutely NOT helpful for my specific problem! –  Felix Dombek Sep 1 '11 at 17:24
    
Try it. It is. After you add the customized date format, re-open MS word 2010 and you'll see. –  wizlog Sep 1 '11 at 19:24
show 5 more comments

I believe the way to do this is the following:

  • Go to the Insert tab in Word
  • Quick parts
  • Field
  • Select Date from the list on the left.
  • Enter your custom date format in the text box on the right (eg. MM-DD-YY)
  • Click OK
share|improve this answer
add comment

In the absence of answers suggesting simpler or more general solutions for adding custom date formats, here's what I did to solve the problem:

  • Rename the .docx file to .zip and unzip the contents to a folder.
  • Open the file word\document.xml in a text editor.
  • Search for dateformat (case-insensitively). There are two hits, something like

<w:dateFormat w:val="yy"/><w:lid w:val="de-DE"/><w:storeMappedDataAs w:val="dateTime"/><w:calendar w:val="gregorian"/></w:date></w:sdtPr><w:sdtContent><w:p w:rsidR="00331636" w:rsidRDefault="00331636"><w:pPr><w:jc w:val="right"/><w:rPr><w:sz w:val="96"/><w:szCs w:val="96"/><w14:numForm w14:val="oldStyle"/></w:rPr></w:pPr><w:r><w:rPr><w:sz w:val="96"/><w:szCs w:val="96"/><w14:textOutline w14:w="9525" w14:cap="rnd" w14:cmpd="sng" w14:algn="ctr"><w14:solidFill><w14:srgbClr w14:val="000000"/></w14:solidFill><w14:prstDash w14:val="solid"/><w14:bevel/></w14:textOutline><w14:numForm w14:val="oldStyle"/></w:rPr><w:t>11</w:t></w:r></w:p></w:sdtContent></w:sdt></w:txbxContent>

  • For both hits, change the highlighted yy to yyyy and change the 11 to 2011.
  • Save the file, zip everything up again and rename the archive to .docx. Done.
share|improve this answer
    
As per the accepted answer, my settings were already set as per my needs. This worked perfectly for me; I'm sure there must be a way to edit the format via the GUI, but a quick tweak of the XML did the trick! Thank you –  Don Vince Sep 15 '12 at 10:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.