Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Dell Precision 490 Workstation, and I just had my other question answered, Install Ubuntu to drive B without impacting drive A, and now I'm having a boot sequence issue.

The external drive is great, boots up fine on my laptop, but how do I tell my desktop to boot from my second SATA drive and not the first SATAdrive.

My drive configuration as follows

  1. SATA-0: Windows
  2. SATA-1: DVDR
  3. SATA-2: Ubuntu

When I choose the boot menu, the option I have is "Internal Hard Drive". I assume it searches all drives, and loads the first bootable one it finds (which happens to be Windows), but I'd like to be able to select the drive from a list.

Has anyone experienced this? Is possible without disabling the first hard drive in the BIOS?

share|improve this question
add comment

3 Answers

  1. While booting the system, hit F2 to go into BIOS setup.
  2. Go into the System tab (top left in the image below)
  3. Change the boot order (actual BIOS setup may not match what I have here) alt text
  4. Save making changes.
  5. Your system will attempt to boot in the order given
share|improve this answer
    
@hanleyp: can you show what you have under "Boot Sequence"? Thanks –  Chris Sep 1 '09 at 21:31
add comment

Some BIOS setups have a separate selection for "drive order" and will only boot from hard-drives in this order where hard-drive is selected as a boot option (so if the first drive has a boot loader installed, none of the others get a look in). My main desktop machine seems to behave this way (USB drive is a separate option, though it only boots of the first USB drive present if there is more than one, as is CDROM but in this case it only boots from the first PATA or SATA drive it sees with boot media, and so on).

If your BIOS is behaving in this way you will need to install your boot loader (lilo, grub, the Windows loader, or what-ever else) on one specific drive, configure it such that it can boot all the OS options you have installed, set that drive in your BIOS as the first drive, and boot from that letting the boot loader give/make the further choice as to which OS to to go with.

If you have a BIOS that functions this when then the other option in this instance is to have USB as your first boot option, set USB above "hard-drive" in the BIOS boot order, and install grub to the USB device during the Ubuntu install (this is controlled in the "advanced" set of options in the last stage of the installation options). That way grub will be given control if said USB device is connected at boot (so Ubuntu will load) and if not the USB phase will pass and the first fixed harddrive with a boot loader will be booted from (presumably loading Windows).

Edit: some BIOSes have a "hit-a-certain-key-for-boot-choice" option presented for a few seconds at startup. My netbook's BIOS does this and the resulting menu allows you to select from all currently detected USB drives instead of just the first found to have a boot loader. It may do the same for PATA/SATA drives but I can't test this as the rest of the motherboard only supports a single such drive.

share|improve this answer
add comment

Some BIOS gives an option only to select internal HDD & not what hard drive to boot from. Normally in this case, there might be another setting which says "Hard disc priority". Check for it & select the HDD you want to boot from.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.