Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Firefox is releasing new version every alternate month.

v4.0 on March 22nd, 2011 
v5.0 on June 21st, 2011
v6.0 on August 16th, 2011

It can be because of the competition with google chrome.

But most of the addons are still aren't supporting newer versions. I realized this today when most of my addons stopped working when my Firefox was updated to 6.0.1

We do have option to increment the version but is there option to get back to previous version. Actullay this questions sounds like "i have windows seven and i want to go back to Win XP " :-P

Downloading previous version and installing it is the only option i see right now. but i dont want to lose Bookmarks,history etc.

Any comment is appreciated.

share|improve this question
    
What addons that you use don't support new version of firefox? (I'm just curious) –  Beniamin Sep 2 '11 at 9:46
    
@Beniamin: That's secret... :P –  Confused Sep 2 '11 at 9:51
    
Be careful using old versions. They have already stopped releasing security updates for version 4. –  David Spillett Sep 8 '11 at 9:19

3 Answers 3

up vote 4 down vote accepted

You can use MozBackup to save all your preferences, bookmarks and addons with associated settings.

You can use oldversion.com to get the version you want.

I personally can wait for the addons to update. It usually is just a number change in the addons themselves.

Edit: You can also change a setting in about:config to force the addons to work. I haven't tried this my self. Also I remember there was a way to enter the addons themselves and manually change them to 6.0.1 (or what version you have).

share|improve this answer
2  
Compatibility Reporter lets you use addons that "dont't support" current version of firefox. You can find it here: addons.mozilla.org/en-US/firefox/addon/…. –  Beniamin Sep 2 '11 at 9:43
    
+1 ..great application and link. –  Confused Sep 2 '11 at 9:58

Actually in most cases your Firefox profile is compatible with multiple versions. I have always gone back and forth between beta and stable releases using the same profile and this only failed to work once (which was easily resolved by deleting a file). In fact you can use one profile with multiple versions of Firefox across different computers and OSes.

All versions of Firefox can be found at http://releases.mozilla.org/pub/mozilla.org/firefox/releases/

share|improve this answer

You can also download Firefox 3.6 on the official website and then only apply the upgrades (4, 5, ...) that you want.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.