Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently converted to Linux (Ubuntu 11.04) and installed Google Chrome (not chromium). To my surprise it works very slow. The firefox included in the ditro is much faster (2-4 times as fast, sometimes more) - consistently.

Strangely enough, a chrome running in a Windows 7 VM (virtual box, NAT bridging) is working much faster as well - just as fast as I was used to before going the linux way.

Why? How can I fix the linux chrome?

Details: Ubuntu 11.04, up-to-date. Linux chrome: 13.0.782.218. Windows chrome: 13.0.782.218 m. No proxy.

share|improve this question
    
Out of curiosity, does chromium run just as slow? –  frabjous Sep 2 '11 at 11:58
    
I faced a similar issue with chromium, not sure if it applies to your situation but it might be worth checking. I discovered that the local DNS server I was using on my router was giving me truncated DNS responses for some lookups and chromium was having trouble with that. nslookup would give me something like ;; Truncated, retrying in TCP mode.. I changed the DNS server and chromium has been much better since. –  arunkumar Sep 2 '11 at 12:36
    
But firefox and windows chrome are working ok... –  Ran Biron Sep 2 '11 at 14:58
    
Chrome has a View Background Pages option, which contains the bandwidth and CPU used by each individual process. (There's also stats for nerds, which just adds on more memory information). Anything using a lot of CPU/memory in there? –  new123456 Sep 2 '11 at 21:34
    
@new123456 - nothing of interest there. I would've been surprised as the machine I'm using a a real beast. Besides - FF and Windows chrome (configured exactly the same) are working great at the same time - so it's something to do with linux chrome, not with a general load on the system. –  Ran Biron Sep 2 '11 at 23:07

1 Answer 1

up vote 0 down vote accepted

Found the issue! Apparently it was DNS resolving - but chrome didn't report it as so. Specifically, mdns services. To fix, edit /etc/nsswitch.conf (sudo of course). Replace this line

hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4

with this (drop mdns4_minimal and mdns4):

hosts: files dns

then restart networking by running:

sudo /etc/init.d/networking restart

Another thing (not related to the question but I found while searching) you can add is "wins" to enable windows domain resolving.

Strange that FF wasn't affected by the same thing. Does it have its own DNS resolving?

share|improve this answer
    
note that by disabling mdns you won't be able to perform "near network" discovery of devices (printers and such). I consider this a small price to pay for proper browsing - but maybe a different mix of options (such as using mdns after dns) would work just as well without disabling that service. –  Ran Biron Sep 2 '11 at 23:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.