Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have configured Thunderbird to download emails from my Gmail account. Essentially, this is back up of my Gmail account. In Gmail settings, I enabled POP download from the date of account creation.

Within a few days, Thunderbird downloaded all the mails from the date of account creation (back in 2004.) When it reached the date from early this year, the downloading slowed down dramatically. Earlier, it used to download 300-600 mails in every fetch request. It now download only one message at a time. At this rate, my mails will take forever to download.

One of the oft-repeated solution to this problem is to disable "Leave Message On Server" option. But, this means, the messages from my Gmail account will vanish and my local copy is no longer a back up copy.

How do I download my mailbox from Gmail at the rate of few tens, if not hundreds, of messages in every fetch request?

share|improve this question
add comment

2 Answers 2

Please try following these troubleshooting steps. You may need to delete your POP configuration and re-add it.

There are also some other back-up solutions that might work for you, if your goal is just to back up your mail. Some volunteers from the Gmail community have been building one called Got Your Back.

share|improve this answer
    
Thanks Sarah. I have found the solution and updated this question. –  Shashikant Kore Sep 3 '11 at 5:16
add comment
up vote 2 down vote accepted

Another thread on Gmail forum has the correct solution.

I resolved this issue as well by following what ant0nis did. Uncheck "Leave messages on the server" in Thunderbird, but LEAVE "When messages are accessed with POP:" to the setting "Keep Gmail's copy in Inbox"

GMail's setting needs be "Mail Settings" -> "Forwarding and POP/IMAP" -> "POP Download" -> "2. When messages are accessed with POP" -> "Keep Gmail's Copy in the Inbox". This setting ensures that the mails don't get deleted from your account even if they are downloaded from a POP email client.

share|improve this answer
    
Shashikant Kore's answer did it for me. MacOsX Thunderbird 17.0 and Gmail. Unchecked Thunderbird's "leave mail on server" and I get them all at once now and they still remain stored by Gmail. –  user181511 Dec 20 '12 at 2:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.