Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am not the original creator of the spreadsheet so I am not sure how the person caused this. The issue is basically the excel spreadsheet has an excess amount of empty cells that won't delete and refuse to go away. I have selected the entire area and deleted it but they still persist. Some spreadsheets go all the way to up 65536 (2^16) and some are just in the thousands. This is an issue with our batch printing program that prints all of our excel workbooks and ends up having thousands of blank pages.

How do I go about getting rid of those cells? I do not want to have to copy the correct cells into separate worksheets to fix this.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

Can you simply copy and paste only the good content into a brand new spreadhseet?

EDIT: Try this instead then: How to reset the last cell in Excel

share|improve this answer
    
I probably can but there's a lot of spreadsheets with this issue and I would like to tell other people how to solve it. –  qroberts Sep 2 '11 at 17:08
    
The KB on Microsoft worked! I had to basically delete all those cells, save it, close and reopen and it worked. –  qroberts Sep 2 '11 at 17:21

What is the "printable area" of the documents?

A spreadsheet in excel will always show all these extra cells, but generally, only those cells with formatting or data will be saved or printed.

Selecting the cells and deleting them will still leave all those extra cells visible, but they should only be printed if they actually contain data.

After deleting the extra cells to clear the data, does what shows up in Print Preview change any?

UPDATE response to comment:

Does the Print Preview show all the extra, unneeded pages that the batch process will end up printing?

Print Area is not the same as page setup. Print Area is the section of the document that can be specifically defined as should be printed when you issue a print command on that file.

In Excel 2003, setting the print area is in the File menu, Print Area, Set Print Area. Select "Clear Print Area" to remove any hard-set print area commands.

In 2010, Print Area is in the Page Layout ribbon, Page Setup section. You can clear the print area here too.

Once you've cleared the print area, Excel is free to determine what ought or ought not be printed by itself. So long as the cells have been cleared of data or formatting, the default print area should shrink to the area actually inhabitted by data.

UPDATE more comments:

At this point I would assume the documents themselves have some sort of corruption going on.

After making the above changes, you may try the "Open and repair" option to try and repair the files. If that fails, copy the data to a new spreadsheet.

I would be interested to know what happens when the batch process prints a "normal" spreadsheet that has not had this issue.

share|improve this answer
    
The paper size is set to letter and all the page setup settings look fine. When I delete the cells the print preview doesn't change. –  qroberts Sep 2 '11 at 16:59
    
I just tried what you suggested in your edit. It didn't change anything :(. I just checked the cells and nothing is referencing any cells that are in the empty cells. –  qroberts Sep 2 '11 at 17:13
1  
qroberts - after deleting the extra cells, you need to save the document and reopen to see the effect. –  variant Sep 2 '11 at 17:14
    
@variant: That is not the case. Any changes should take affect immediately. A save is not even necessary. –  music2myear Sep 2 '11 at 17:15
    
@variant That worked! I tried it first by reading the KB on Microsoft and that fixed it. Not sure why it didn't auto-update. –  qroberts Sep 2 '11 at 17:21

Heads up... if a row/column has a custom height/width even if it is completely blank and waaaay out there Excel will assume it is important and lengthen the scrollable area to allow you to reach it.

To fix it, multiselect all affected rows/columns and set them back to their default heights/widths manually, using the context menu option.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.