Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After converting a Parallels VM to VirtualBox, the converted VM still does not run. VirtualBox says:

VT-x/AMD-V hardware acceleration has been enabled, but is not operational.... Please ensure you have VT-x/AMD-V enabled in the BIOS of your host computer

Only I have no such option in my BIOS even after upgrading to the latest firmware yesterday. Turning VT-x/AMD-V Acceleration off in the VM Settings does not work since VirtualBox re-enables it again automatically.

The question is how to get this VM to run?

  1. Can VirtualBox really be make to run the VM without VT-x/AMD-V acceleration? The same machine works in Parallels, so it is obviously possible on the same H/W.
  2. Can the VT-x/AMD-V technology be enabled some other way? My CPU is an AMD Phenom II X4 945 and the motherboard is an ECS A785GM-M.

All this is running under OpenSUSE 11.2 64-bit with VirtualBox 4.0.4.12 and Parallels Desktop 4 (which is why I am stuck at 11.2 and trying to get VirtualBox to work).

share|improve this question
    
From what I can tell the motherboard should just automatically enable AMD-V if you processor supports it (which yours does). Have you ensured no other virtualization engines are running at the same time (ie: Parallels)? –  techie007 Sep 2 '11 at 18:13
    
Interesting! Parallels is not running but there may be a daemon in the background. Any idea how to check and disable it temporarily? BTW, simply killing the Parellels processes did not work (the processes are gone but VirtualBox still complains). –  Itai Sep 2 '11 at 18:23
    
Assuming you're using Parallels for Mac, then not I specifically, as I'm not a Mac guy, so I can't spew step-by-step directions. :) Perhaps ask that as another question if a similar one can't be found on here? –  techie007 Sep 2 '11 at 18:27
    
Parallels for OpenSUSE 11.2 (Linux) running Windows 7 64-bit as the Guest oS. So, I'm not a Mac guy either. –  Itai Sep 2 '11 at 18:37
1  
Back already from a couple of reboots and yes you got it. Parallels runs a system level service which I disabled in YaST (OpenSUSE's control panel) and now VirtualBox does not complain. It tries to boot the machine which gives a BSOD but I guess that's for another question. –  Itai Sep 2 '11 at 18:54
show 2 more comments

2 Answers

up vote 3 down vote accepted

From what I can tell that motherboard should just automatically enable AMD-V if your processor supports it (which yours does).

Perhaps ensure no other virtualization engines are running at the same time (ie: Parallels), as they may be keeping the (AMD-V) VT sub-system busy, and so VirtualBox can't use it.

share|improve this answer
add comment

The BIOS may be obscure on where the VT-x/AMD-V is enabled, for example, no where in an Asus M5A88 mobo with AMD FX6100 cpu does it even remotely resemble any mention of VT-x/AMD-V.

One very helpful blog I found mentioned to look in Northbrige (under the chipset), nothing there either however, in the CPU Configuration there is a selection "Secure Virtual Machine Mode" it was disabled, once enabled and rebooted, Ubuntu 11.10 64bit desktop installed without issue in Virtual Box.

You can check to see if it is enabled if you get an output via terminal

$ cat /proc/cpuinfo | grep "vmx svm"
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.