Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The same issue has been reported here

The files exist in the regular system folder, but they are missing from the list in System Preferences.

enter image description here

Similarly, only 1 folder of Desktop Pictures is still there. The other standard folders (e.g. Black and White, Abstract, Nature, etc...) are missing.

enter image description here

I've tried repairing disk permissions, but that didn't help.

share|improve this question

If permissions repair didn't fix it, try this:

ls -la /Library/Desktop\ Pictures/

Make sure there are some sort of whacked out permissions. If so:

sudo chown -R root:admin /Library/Desktop\ Pictures/ && sudo chmod -R 644 /Library/Desktop\ Pictures/

The above chmod to 644 will do the directory recirsively so, you will then want to go behind and do:

sudo chmod 774 /Library/Desktop\ Pictures/Art
sudo chmod 774 /Library/Desktop\ Pictures/Black\ &\ White
sudo chmod 774 /Library/Desktop\ Pictures/Nature
sudo chmod 774 /Library/Desktop\ Pictures/Patterns
sudo chmod 774 /Library/Desktop\ Pictures/Plants
sudo chmod 774 /Library/Desktop\ Pictures/Solid\ Colors

Sometimes Mac permissions require a little bit of forceful massaging. :P

Also I just notice you said Lion. If there are any other directories in /Library/Desktop\ Pictures/ that I didn't mention in the chmod 774 block above do them in the same fashion.

share|improve this answer
As it turns out, a clean install of Lion doesn't include the other folders. I didn't realize that. So, I went to an older mac and copied the desktop pictures folder to the new mac. Thanks for your suggestions. – John Douthat Sep 3 '11 at 16:51
A clean install should include those folders - at least I have them, I don't know what happened in your case. – Vervious Sep 4 '11 at 7:03
Clean install of Lion is somewhat of a red herring anyway. Unless of course you purchased the USB flash drive media. Otherwise all installs of Lion are just in place upgrades to Snow Leopard, which does include these folders. I can hardly imagine these are removed on purpose simply by installing Lion. This is definitely an interesting one. I'm not upgrading to Lion any time soon. Having watched Lion grow from the Developer side, I will wait until all of the energy/temp concerns have been fully ironed out on all platforms before upgrading. At any rate, at least your problem is solved! – C0D3M0NK3Y Sep 4 '11 at 18:04
I did a clean install of Lion from the recovery partition after formatting the primary partition. After installation, they were not there. Snow Leopard has never been on this computer. – John Douthat Sep 5 '11 at 19:58

I had Lion installed for 6 weeks before I had the problem of my screensaver options disappearing which appears to have occurred after I had to start MacBook Air in 32 bit mode. I am not saying that this was necessarily the cause but it was very coincidental.

I tried the answer provided above with no apparent effect - I must admit I did not think to restart the computer afterwards. Anyway, I eventually remembered that I had used the computer in 32 bit mode and, although it had been restarted since (but not after applying the answer above), I wondered if it actually had reverted automatically to 64 bit mode.

When I restarted the computer in 64 bit mode, I had my screensaver options back. So I don't know if restarting after applying the answer above would have fixed it or restarting in forced 64 bit mode fixed it, or a combination of both.

share|improve this answer

All needed to do was reinstall OS X Lion. Once I did, the permissions were repaired.

Either open the installation file you downloaded, or restart your computer and hold option. Once you see "Recovery HD", pick that as your drive and click "Reinstall OS X Lion". That should do it.

share|improve this answer

I have this problem when switching between my Apple Cinema display and my MacBook Pro's built in display. The Screensavers appear correctly when it is connected to the Cinema display, but then disappear when changing to the MacBook's LCD.

Solving the problem did not require any permissions changes, reinstalls or reboots. Instead, I open up System Preferences and go to Displays. Next, I change the resolution to something else, then change it back to the normal resolution. When I change back to the Screen Savers preference pane, all of the Screensavers are visible again.

share|improve this answer

You must log in to answer this question.

protected by Community Apr 24 '12 at 9:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .