Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I don't want Skype to update itself whenever it wants.

I did some research and found that some people went back to SkypeSetupFull 4.2.0.187 and reported that this version doesn't update itself. I also found that even some of the 4.x versions will update themselves.

I went ahead and uninstalled Skype (latest version 5) and manually removed (almost all) Skype entries from the registry. I installed 4.2.0.187 but it still updated itself.

How can I configure Skype so that it won't update itself automatically on Windows 7?

share|improve this question
    
Turning off in Automatic Updates does not work... –  Theta30 Jul 7 '13 at 5:06
    
This is a 3 year old question that has gotten new activity in July 2014 most likely because Skype has recently (within weeks) "expired" most prior versions of the client blogs.skype.com/2014/07/16/… –  Tyson Jul 30 '14 at 14:33

5 Answers 5

up vote 4 down vote accepted

You should be able to, in Skype, go to Tools -> Options -> Advanced and change automatic to notify me then hit save

If Skype updates before you're able to change this setting you might need to look at blocking it with your firewall or disconnecting from the Internet.

share|improve this answer
    
The tricky part is that you cannot disable auto update if you are not logged in..... –  Radek Sep 3 '11 at 3:48
1  
As Skype now belongs to Microsoft Skype update are also shipped via Windows Update. I doubt that this setting also affects Windows/Microsoft Update. –  Robert Nov 19 '12 at 15:36

The thread I want to turn off automatic updates contains several methods for disabling the auto-update of Skype, in addition to turning off updates via Tools > Options > Advanced > Automatic updates. Below is a summary of the three that look the most promising.

Method 1 : Block the Skype update website

  1. Quit Skype
  2. Remove any copies of SkypeSetup.exe that has been automatically downloaded by Skype on your computer (usually in the TEMP folder)
  3. Add the line 127.0.0.1 download.skype.com to your hosts file

Method 2 : Firewall and registry

  1. Block the following IP addresses in the firewall: 193.95.154.39, 204.9.163.158, 204.9.163.247, 213.166.51.4
  2. Set the registry entry:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Skype\Phone] "DisableVersionCheck"=dword:00000001
  3. Empty the TEMP directory

Method 3 : Registry updates (not recommended)

This is described in this answer where a registry update script is supplied.

  1. Stop Skype and end it via the taskbar icon.
  2. Delete the following files: C:\program files\skype\updater\*.* and %TEMP%\Skype*.*
  3. Stop the Skype Update Service via Control Panel > Services, and deactivate it.
  4. Delete the described keys from the registry
share|improve this answer
    
Note: As the methods 1 and 2 do not conflict, they can both be used together. –  harrymc Jul 11 '13 at 8:07
    
The way I did was: 1. deleted the update folder 2. deleted traces of the update folders in key registry 3. cleaned temporary folder. It worked –  Theta30 Jul 27 '13 at 3:24

You can turn off automatic updates in the latest version of Skype for Windows 7 by:

  1. Open options (under tools menu)
  2. Select the "Automatic Updates" tab from the Advanced sidebar
  3. Click "Turn off automatic updates"

This is documented by Microsoft here

You might have to further disable Microsoft updates as a part of Windows update.

share|improve this answer
    
I wrote in a comment that "Turn off automatic updates" does not work –  Theta30 Jul 12 '13 at 22:14

One thing to note (solution provided) is that even if you have turned off or blocked automatic updates, if Skype has already downloaded an update for you, it will prompt you every time when you start Skype to apply the update. No amount of further blocking - by IP, Firewall, hosts file, Settings interface, etc. - will stop this.

What you need to do is this:

1. Go to your Temp folder

Start Menu->Run->%temp% 

2. Delete SkypeSetup.exe

3. Restart Skype - should be fixed now!

share|improve this answer

Open Services, double click SkypeUpdate, double click, set to Disabled. Should work But doesn't, though it remains disabled, stupid skype keeps asking me if I want to update! Pity about that

But the new (Dec 2014) version of skype does include spell checking by default. This is the best thing about the update, everything else is rubbish, particularly its handling of transferred files, images in particular. I will stay with the prior version til MS gets it sorted.

If you stay with the older version, SpellCheck doesn't seem to work even if you turn it on in PC Settings, Typing, even though there is a link to this in Options. So you have to fall back on Ursa or TinySpell. Ursa costs $10 (after a month) while TS is free, but can be annoying as it works in other applications as well as skype.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.