Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I press Ctrl+Backspace, sometimes a small square is inserted, instead of the entire word being erased. If I copy and paste the character here, I get this: ``. But it doesn’t look quite like that in the text box – there it’s just a plain white rectangle with a 1px black border.

The problem only happens in some text boxes; in others the shortcut works like it should.

  • Start menu search box: works
  • Notepad: doesn’t work

    small box created from Ctrl+Backspace in Notepad

  • Notepad2: works
  • Firefox: works

I’m running Windows 7 x64.

share|improve this question
I get the same behavior in notepad in WinXP. – djhowell Aug 31 '09 at 20:08
I also get this behavior when renaming a file in File Explorer on Windows 7. That is, when I select a file, press F2, move the cursor to the end of the word I want to delete, and try Ctrl+Backspace. – Rory O'Kane Aug 26 '13 at 21:35

The "box" you're seeing is what is known as a control character. The box is displayed because, as you've discovered, not all programs handle the ctrl+backspace to remove a word.

This control character is one of 33 "non-printing" characters in the 128 character ASCII character-encoding scheme.

share|improve this answer
Just wanted to add that some applications handle it even worse and actually don't display the control character. You can see this when nothing happens with ctrl+backspace and pressing delete seems to do nothing. I think notepad for Vista did this. – Joshua Aug 31 '09 at 20:19
The character inserted is 127 - the delete character. – ugh Aug 31 '09 at 20:25
Link to ASCII char 127, the delete character, on Wikipedia – Rory O'Kane Aug 26 '13 at 16:20
This explains the obvious 'what', but not 'why' :-( – mafu Nov 4 '15 at 8:33

You can fix this behavior by overriding the Ctrl+Backspace shortcut using AutoHotkey. Save the following code in a plain text file with the given filename and extension, then launch the script with AutoHotkey:


; how to write scripts:

#IfWinActive ahk_class CabinetWClass ; File Explorer
#IfWinActive ahk_class Notepad
    Send ^+{Left}{Backspace}

; source and context:

; relevant documentation links:
; writing hotkeys
; list of key codes (including Backspace)
; the #IfWinActive directive
; the Send command

You may find it easier to download this script file from GitHub, rather than creating the file and pasting in its contents yourself.

To launch this script automatically on startup, add a shortcut to it to the Startup folder in your Start menu, as described in Run a program automatically when Windows starts.

The basic idea of the script is this:

^Backspace:: Send ^+{Left}{Backspace}

This changes the Ctrl+Backspace shortcut in all programs so that it is equivalent to pressing Ctrl+Shift+, to select the previous word, and then Backspace, to delete it.

This select-and-delete workaround, while better than typing a box, is brittle. It’s safer to not enable this shortcut in programs in which Ctrl+Backspace already works. That’s why I use #IfWinActive to limit the hotkey to only programs that I know don't support that shortcut.

share|improve this answer
Helped a lot! Thanks for sharing your know-how. :) – Martin Pfeffer Jul 3 '15 at 3:29

Found this on an MSDN blog...

A few people in the early days of the Internet Explorer group used the Brief editor, which uses Ctrl+Backspace as the shortcut key to delete the previous word, and they liked it so much that one of them added it to the autocomplete handler. Therefore, any edit control that uses SHAutoComplete will gain this secret Ctrl+Backspace hotkey.

So it sounds like if the application does not use SHAutoComplete it will not support the feature unless it has been explicitly added by the application's author.

P.S. control-delete removes the word ahead of the cursor

share|improve this answer
Also on this same article, reading through the comments adds a little bit more insight:… – heavyd Aug 31 '09 at 20:17

Not all applications handle keyboard shortcuts the same. Notepad doesn't seem to handle this key combination and handles it in its own way.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.