Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have downloaded Windows 7 x64 from MSDN. I have checked the hash of the file and it is correct. I have them made a bootble USB stick ( (had to use my vista bootsect.exe as running 32bit at the moment). When I boot from the USB it fails when expanding the file. It stays on 0% and fails after around 90 seconds. The error is 0x80070017. As the hash is correct and I am using USB I guess it could be a hardware problems. Any advice how to get Windows 7 installed? The machine is a Dell Studio Slim.

share|improve this question

The error code you're seeing is ERROR_CRC:

Data error (cyclic redundancy check)

The usual follow-up would be to verify the contents of the installation media. You've mentioned that the "hash is correct"; did you make sure to re-hash the media after copying it onto your USB key? (It's possible that a few bits got flipped between the downloaded copy and the copy on the key.) Alternatively, do you have another USB key or device that you could try?

share|improve this answer

try WinToFlash

worked for me with win7x86.

share|improve this answer
Same problem as before – Liam Aug 31 '09 at 21:24
can you try on another computer? – Molly7244 Aug 31 '09 at 21:43

You are all wrong ;) except for the use of a bootable USB.

The 0x80070017 means the DVD did not burn correctly, or the ISO image was corrupted.

Make sure the MD5 checksum of your ISO file is: 758887088235024058d1c8eb6efb85a8

3.00 GB (3,224,686,592 bytes)

If they match, try burning that ISO on a different computer with a DVD burner.

I had this same problem and I fixed it.

Also if your do the win7 upgrade from 32 bit to 64 or just a 'clean install' from the 'upgrade' you will need a registry hack.

share|improve this answer

Try formatting the drive. I tried installing on top of a Vista partition and had the same problem. Deleting partition and recreating solved the issue for me.

share|improve this answer

I have had this before and it was down to corrupt memory. Run a memory checker on your machine such as memtest86+

share|improve this answer

You must log in to answer this question.