Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to set a simple public block for an application for both inbound and outbound connections. I'm using Windows 7, but my friend is still able to connect to the application. Steps I took are as follows:

  1. Reset firewall to default settings using the button at "Control Panel\System and Security\Windows Firewall"
  2. Go into advanced settings from the same place
  3. Add an inbound rule for the target application with public checked using TCP (program does use TCP)
  4. Add an outbound rule in the same way
  5. Close all windows and restart target application

Now at this point, my friend is still able to connect. I've even enabled logs for both dropped and accepted connections. Nothing was logged.

Any ideas? I'm not feeling very safe here.

share|improve this question

migrated from serverfault.com Sep 3 '11 at 21:49

This question came from our site for system and network administrators.

1 Answer 1

up vote 3 down vote accepted

It works fine. "Public" refers to the network profile Windows has detected (Home, Work, Public) not "Allow/Disallow Access From (Home/Work/Public) Computers".

I assume your network is set to Home.

share|improve this answer
    
the firewall is set to block all incoming connections that aren't on the list of allowed programs for both private and public networks. the profile of the rule is set to allow connections from private only. what can i do to make that work as i intend (only localhost can access the service)? –  Mina Sep 3 '11 at 22:55
    
What does "allow connections from private only" mean? If your network profile for the connection is "Private" and you port forward from your router's WAN interface to your PC then connections on this port will be treated as "Private" regardless of origin. You've said that "I'm running on this profile so use these sets of rules". As for localhost only, remove any exceptions. Local traffic doesn't go through the firewall. –  ta.speot.is Sep 3 '11 at 23:02
    
i see, so i'm misunderstanding the meaning of private then. thanks for the info, i'll just remove that profile and see how it goes~ i assumed private meant hosts on my lan, is it possible to set a rule to allow any lan hosts? –  Mina Sep 3 '11 at 23:10
    
Windows XP had a "Local Subnet Only" setting in it's firewall, I assume there is a Windows Vista/7 equivalent - i.msdn.microsoft.com/dynimg/IC117914.gif –  ta.speot.is Sep 4 '11 at 0:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.