Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In OSX Lion, in vim, I try use this nnoremap.

nnoremap <m-Down> :cnext<cr>zvzz
nnoremap <m-Up> :cprevious<cr>zvzz

vimrc from sjl

I added the nnoremap to ~/.vimrc, but when I press ALT-Down nothing happening.

share|improve this question

1 Answer 1

If you are using Vim in Terminal.app, the Alt key doesn't work by default. You must enable it in its preferences, it's a checkbox labeled "Use option as meta key" in the settings panel.

But you could use MacVim which understands the Alt key by default.

But you could use <leader><Down> and <leader><Up> which are going to work everywhere, :help mapleader.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.