Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is a strange one. I just bought a Netgear WNA3100 wireless USB adapter. I put in the installation CD, clicked "setup" and the driver installation did its thing. When it told me to plug the device in, I did so, and Windows tried to install drivers for the device (like it does for every device). After a few seconds, I got the dreaded "This hardware was not installed correctly" message from the windows task bar. As this was going on, the Netgear installation was still trying to find the device, but it couldn't. After about 10 minutes it quit the install with an error saying "Couldn't find the device".

If I look in device manager for the device, the status is "The device cannot start. (code 10)"

Just to make sure this device was compatible with Windows 7 64-bit, I tried it again on my laptop which is Windows 7 64-bit Professional. The installation worked an absolute charm.

Microsoft's website also confirms the device is compatible: http://www.microsoft.com/windows/compatibility/windows-7/en-us/Details.aspx?type=Hardware&p=Netgear%20N300%20USB%20Wireless%20Network%20Adapter&v=Netgear&uid=WNA3100&l=en-US&pf=0&pi=1&s=wna3100&os=64-bit

Does anyone have a clue what might be going wrong? I'm starting to think it's a USB problem, as it works on my laptop.

Also it's worth mentioning that I was using the very latest driver setup from the Netgear website.

share|improve this question

1 Answer 1

You don't mention what computer you are plugging into, but double check you are not trying to use a USB2 device in a USB 1 or USB 3 slot.

share|improve this answer
    
My motherboard does support USB 3, but the port I'm plugging it into a USB 2, and the adapter is USB 2 aswell. –  Chris Sep 4 '11 at 13:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.