Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Apple Mail with IMAP account. I have several filtering rules defined. The problem is that Mail doesn't apply them automatically to incoming email. Even spam isn't filtered automatically.

For all incoming email, every time, I have to select e-mails and select "Apply Rules", and then rules work fine (that one time on selected e-mails only).

It works like this on two separate installs of Mail with different accounts (both IMAP though).

How can I get Mail to apply all rules automatically every time to all e-mails?

I wonder does it ignore rules because of misconfiguation, bug or does Apple seriously expect people to use "Apply Rules" menu item regularly?

share|improve this question
add comment

3 Answers

This is a bug.

In their infinite wisdom, Mail.app developers decided only to apply rules to 'unseen' messages. If the IMAP 'seen' flag is set, rules will not be applied.

I started a forum thread on the apple forums on this topic.

share|improve this answer
add comment

Not sure if this is exactly your problem, but something similar happens to me.

I've got a Mac running Apple Mail and an iPod touch, both checking the same IMAP account. The Mac is asleep during the day. While out and about, I'll check my mail on the iPod, read the new messages, and leave them in my inbox. When I come home, I wake up the Mac, and Mail syncs with the server. The filtering rules are not applied.

The reason for this behaviour is that Mail only appears to apply rules to "new" mail. Having already seen these new messages on another device, I'm not so much downloading new messages to Mail as I am synching with the server. So, no rules applied for these messages.

share|improve this answer
add comment

I had the same issue, but it turned out the first rule in the list (News from Apple) had "Stop evaluating rules" as the last action.

I removed this action and it worked fine.

share|improve this answer
add comment

protected by Community Sep 27 '12 at 14:37

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.