Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed the latest VirtualBox 4.1.2 and Ubuntu Server 11.04.

After playing around with the network settings, I found there's no IP address configured for eth1 and eth2. I think I used to have eth0.

image

Network reads:

Adapter 1: Intel PRO/1000 MT Desktop(Host-only adapter, "VirtualBox Host-Only Ethernet Adapter")  
Adapter 2: Intel Pro/1000 T Server (NAT)

How should I setup VirtualBox and Ubuntu so that I can access it as a guest from Windows 7? Ubuntu should also be able to access the Internet.

share|improve this question
add comment

migrated from stackoverflow.com Sep 4 '11 at 20:43

This question came from our site for professional and enthusiast programmers.

1 Answer

Start with the setting of nat for the nics in virtualbox. This should allow you to access the internet through your host pc. If I understand what you mean by "guest" (you want to be able to ssh into the vm, and access its server processes as a client from windows7) you want to use bridged-networking. This will setup a network you can use to communicate between host and guest.

Just to be clear, set the nics as nat and make sure you can access the internet. When that is working, shutdown the vm, and change nic2 to use bridged networking. ifconfig eth0 and ifconfig eth1 should show you different networks.

share|improve this answer
    
what is the difference between a bridged network and a virtual host only network? i tried to create a bridged network, but i lost my internet connection. –  resting Sep 6 '11 at 15:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.