Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A friend backed up an in accessible Windows 7 partition to a big (close to 1TB) external USB drive using KNOPIX. Unfortunately the umlauts and accents in the file names of his extensive music collection now appear garbled (UTF8 vs ISO xxx, I guess) when he accesses that drive from Windows.

My guess is he needs to mount the two drives in a 'special way,' that takes the diacritics translation into account, on KNOPIX? Or do you have another idea what went wrong?

This is the second part of a windows/linux problem I'm having. See how-does-one-mount-a-partition-in-windows-7 for the other part

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Make sure your system (Knoppix) is using an Unicode-based locale (UTF-8):

$ locale
LANG=en_US.utf-8
LANGUAGE=
LC_CTYPE="en_US.utf-8"
[skipped irrelevant settings]
LC_ALL=

If the LANG or LC_CTYPE variables do not end in .utf-8 (or .utf8), fix them:

  1. run locale -a and make sure it lists the needed locale (i.e. en_US.utf-8);

  2. if the locale is not listed, uncomment it in /etc/locale.gen:

    en_US.UTF-8 UTF-8
    

    and run locale-gen as root;

  3. run export LANG="en_US.utf-8"

  4. run (xterm &) or (gnome-terminal &) to start a new terminal with the new settings applied;

  5. close the old terminal. (It is not enough to change $LANG for the current shell.)

In the new terminal, verify output of locale and check whether it fixes your problem.

Also make sure your filesystem driver is using UTF-8. The NTFS filesystem uses Unicode exclusively, but if you mounted it while having an incorrect locale, the driver might be in a translation mode. Unmount the filesystem and mount it again, while having a correct $LANG. If even that does not help, try adding the utf8 and iocharset=utf8 options to mount...

# mount -t ntfs -o utf8,iocharset=utf8 /dev/foo /mnt

...or switch to the ntfs-3g driver:

# mount -t ntfs-3g /dev/foo /mnt
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.