Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Text fields in almost all software erase a word when ctrl+backspace is pressed. However, Notepad behaves differently, and inserts a character which is:
`` (I copy-pasted it here. I'm not sure if it is visible. It looks like a rectangle in Notepad.)

Here is a screenshot:

ctrl+bksp

  • What is this character?
  • Why does Notepad do this? Is it simpler to implement?
  • Are there other key combinations for other characters?
  • Is there a key combination in Notepad for erasing a word?
share|improve this question

1 Answer 1

up vote 13 down vote accepted
  1. It's 0x7F "Delete" in ASCII and U+007F "Delete" in Unicode.

  2. It's in fact lack of an implementation. Plain Backspace sends an ASCII 0x08 (I'm not sure how the Edit control handles it internally), and it is not uncommon in various operating systems for CtrlBackspace to send the "Delete" sequence.

    The "delete word" behavior was added later, as an undocumented feature, and only to those Edit controls which use "SHAutoComplete". If a textbox has autocompletion disabled, CtrlBackspace will likely not work.

    (SomeMany programs implement their own text editing controls, which work slightly differently from the built-in one.)

  3. CtrlJ and CtrlM will get translated to a newline (^J is CR in ASCII and ^M is LF; however, the Edit control translates both keypresses to CR+LF.) Similarly, CtrlI inserts a Tab character.

    Ctrl_ and Ctrl^ will result in somewhat useless "Unit separator" (^_) and "Record separator" (^^).

    (The ^X notation means the Ctrl key – Ctrl-X in this example – in ASCII this is equivalent to unsetting the 7th bit of the following character.)

  4. No, but you can use CtrlShift← Left to select the previous word, and overwrite by typing.

    Or get a better Notepad.

share|improve this answer
    
Thanks for the response grawity. But I don't understand why you rejected @RJFalconer's edit. [Ctrl][Left] does not select without [Shift]. –  musa Sep 6 '11 at 6:48
    
@musa: I didn't, that just happens when two people are editing at once. –  grawity Sep 6 '11 at 7:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.