Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We get our office broadband through a BT Business Broadband WiFi router. We have a mixture of macs and windows PC/laptops connecting to it at any one time.

All devices are able to connect to the wireless signal with pretty much full signal.

However, only two computers (one windows, one os x) are able to consistently connect to the internet. The other three (one windows, two os x), while they can always connect to the wifi, exhibit one of three characteristics.

  1. No internet at all.

  2. Programs like Skype work, but no internet through a browser.

  3. Internet works, but with intermittent lag when switching between different sites. I'm assuming while trying to resolve different addresses.

Ignoring point 1 for moment, my gut is telling me DNS. It is an up to 20MB line that usually gets to between 13MB and 15MB downstream. The router is capable of dealing with the amount of wireless devices that we're throwing at it.

Has anyone got any suggestions for how I might further diagnose this problem (preferably in OS X)?

Rich

share|improve this question
    
Wait, you mean Skype works with no internet?! –  That Brazilian Guy Aug 20 '13 at 12:37

7 Answers 7

This indicates improper DNS configuration.

The reason why Skype still works but not web browsers is because Skype doesn't rely on DNS. Make sure you have the correct DNS server addresses for your network interface or use the router's IP address instead.

share|improve this answer
    
I'd agree, from what we know so far. To help confirm this, put 64.34.119.12 in your browser and let us know what you get (detailed messages, please, if you get anything but this site). –  StevenV Sep 5 '11 at 13:29

I had the same problem for many months trying to connect to any Wi-FI and it did not work.

Finally, I went to Wireless Network Connection Properties, Internet Protocol version 4, and I found, by mistake I have given Use the following DNS server address with a IP address

When I made it Obtain DNS server address automatically, Internet started working through Wi-Fi again.

share|improve this answer
    
After half a day my internet stated working. Your solution worked for me. Any guess how the DNS might have changed automatically? –  Ali Sep 10 '13 at 6:32

Try to ping 74.125.224.244 and then ping Google.com. If the former works and the latter fails you have a dns problem.

Try to manually override the DNS settings on the local machine to connect directly to a known DNS server. If this work then the router has a problem with the DNS servers it provides for DHCP (assuming you use DCHP). (And connecting directly gives a little speed-up on new look-ups btw.).

If you can, login to the router and try change the DNS settings it uses for DHCP (it can be external servers, doesn't have to be BT). Also check the DHCP settings and the range it uses (ie. see if you have enough "slots" etc.).

share|improve this answer
  1. Left click the network icon on the bottom right.
  2. Right click the connection you are using and select Status.
  3. Click Properties.
  4. Select Internet Protocol Version 4 (TCP/IPv4) and then click Properties.
  5. If the DNS is set to Obtain DNS server address automatically, then set it to Use the following DNS server addresses. Put any working DNS, such as 8.8.8.8 (Google's Public DNS) , and then click OK or Close until all of the windows you just opened are closed, and then try again.
    • If the DNS options are already set to Use the following DNS server addresses and there is a DNS server filled in, then change it to Obtain DNS server address automatically or put a known working DNS like 8.8.8.8 for the DNS server IP address.
share|improve this answer

The above answers are correct. You are having problems with the DNS settings on the flawed hosts. What I can add is you may have problems with DHCP also. As long as you get your LAN settings automatically it means your DHCP doesn't work correctly giving a mistaken dns address to the hosts. When I had such a problem in my office, using Windows machines, I typed at the command prompt (run as administrator):

ipconfig -renew all

share|improve this answer

I've had the exact problem:

So it turned out to be a DNS problem, and the only thing that worked for me was to call the IPS and tell them to reset the modem through their system (Take note that manually resetting it in your home will not work), and that fixed the problem.

share|improve this answer

This indicates improper DNS configuration.

The reason why Skype still works but not web browsers is because Skype doesn't rely on DNS. Make sure you have the correct DNS server addresses for your network interface or use the router's IP address instead.

My solution is

  1. Open Network and Dial-up Connections
  2. Right Click on connection and select 'Properties'
  3. Select Internet Protocol (TCP/IP)
  4. Click 'Properties'
  5. Click on 'Advanced'
  6. select Tab DNS
  7. add route DNS IP (192.168.X.X) Save it.

In my case, a after the .168. I have 1 and 2 digits for IP address and 1 and 3 digits for gateway.

share|improve this answer

protected by Mokubai May 25 '14 at 13:17

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.