Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every time I want to change the font (in various applications), the default preview text is "abcdefghijk ABCDEFGHIJK", I can change it but the changes only live for the lifetime of the dialog. They're forgotten immediately afterwards.

The problem with this default is it only shows English characters.

How can I permanently change the preview text?

I'm running xubuntu (i.e. the desktop is Xfce)

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Xfce means your font dialog is from GTK. This is important, because now we know what to modify.

1. This might be a bit windowsese, but try hexediting /usr/lib/libgtk-x11-2.0.so and changing that string into whatever you like (as long as the length of new string is the same as the old one).

2. This string is locale-dependant, so you can modify your locale's translation of this string. This file is probably /usr/share/locale//LC_MESSAGES/gtk20.mo.

Firstly unpack it with unmsgfmt (I don't know where can you find this program in ubuntu), or take the original .po file from gtk source package. Make your change, compile with msgfmt, put the resulting file in the original directory.

Both modifications will probably go away during update. I don't thing there's a setting somewhere to set this string. Therefore...

3. It might be a good idea to ask GTK developers to implement this as a kind of settings. I guess there is no proper place in any graphical environment to set this kind of stuff, so I think the most probable way is to set this in .gtkrc. The proper place to file a bug is bugzilla.gnome.org.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.