Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

While trying to do a backup on a new netbook with Windows 7 Starter, I'm getting the following error in the Event Viewer:

Event ID 12348
Volume Shadow Copy Service warning: VSS was denied access to the root of volume \?\Volume{f699b9db-c6e3-11e0-9c7c-90a4de532e50}. Denying administrators from accessing volume roots can cause many unexpected failures and will prevent VSS from functioning properly. Check security on the volume, and try the operation again.

From looking in the registry, I can tell that the volume in question is the Q: drive, which is labeled "Microsoft Office Click-to-Run 2010 (Protected)".

Apparently that partition is created by Office 2010 Starter, which came with the netbook. Trying to look at its security settings gives the error, "You do not have permission to view or edit this object's permission settings", even though I'm logged in as an administrator. Therefore, I can't even get to the screen where I could take ownership, or make any other security changes.

I am only backing up the C: drive, not the Q: drive. My guess is that when the backup program (Retrospect 7.7) tries to access VSS, VSS somehow wants access to all local drives, even though the backup program may not need them all -- but I don't know for sure.

I tried following the instructions in the post Volume Shadow Copy Service warning: VSS was denied access to the root of volume (Win 7 Home Premium), which says to run "icacls C:\ /grant system:f", but it didn't help, even though the command said it was successful. After discovering that the error is actually complaining about the Q: drive, I tried it on that drive as well, but received an "access denied" error.

I don't want to uninstall Office 2010 Starter, which seems to be the only way to get rid of the Q drive. But if I could figure out how to give VSS access to the Q drive, it might solve the problem.

Suggestions welcome.

share|improve this question

1 Answer 1

up vote -1 down vote accepted

Problem solved.

It turned out to be that the 100 MB SYSTEM partition on the netbook didn't have enough free space. I don't exactly understand why that would cause a problem, but it does. I found out because Windows Backup has the same problem, and someone else found out how to fix it.

The solution is to increase the SYSTEM partition from 100 MB to 450 MB using a partition manager program. Then both Retrospect and Windows Backup work fine. A full description of how to change the partition is here:

How to fix Error code: 0x81000033 when using Windows 7’s Backup and Restore

Note that in his description on page 2 (where the actual solution starts), he mentions two partition manager programs. One requires a bootable CD, which won't work in this case since the netbook doesn't have a CD drive. The second program, EASEUS Partition Master, worked fine for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.