Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I receive a weekly report in Thunderbird (7.0) from the CMS i use for my website. It shows everything in the correct layout but no images. It shows there are 48 attachments vs showing the embedded images.

Anyone have any idea how to get thunderbird to show correctly?

When I login to Google (I use Google Apps) and view the email everything displays fine. Also the email format is in HTML and I DO have "Show remote content" turned on. Note: the CMS logo shows just not the embedded images. Also I have checked the option that says "Display Attachments Inline" Still no go.

UPDATE

Looking into the information provided by harrymc it appears that the problem has to do with the way it is sent. Something about Microsoft Word/Outlook issue. I found this code when I looked at my source:

Content-type: application/octet-stream
Content-Transfer-Encoding: base64
Content-Description: Online-Sales163664
Content-Disposition: attachment; filename="Online-Sales163664"
Content-Type: image/png
Content-ID: <Online-Sales163664>
Content-Disposition: inline

It should say: Content-Type: image/jpeg; vs octet-stream

Any way to correct this?

share|improve this question

1 Answer 1

up vote 3 down vote accepted
+50

From mozillaZine's Images in messages do not appear :

Ensure that the menu entry View > Message Body As specifies "Original HTML".
If it does so already, switch to "Simple HTML", exit and relaunch Thunderbird.
If the problem is still there, restore to "Original HTML" and relaunch.

If you are still unable to view images :

Messages marked as Junk are normally "sanitized", meaning that they are displayed without any images or other HTML formatting. To change this behavior, go to "Tools -> Junk Mail Controls", click on the "Settings" tab, and uncheck the box for "When displaying HTML messages marked as Junk, sanitize the HTML".

If you are using Thunderbird with a proxy, it is possible that this is the source of the problem. Try adjusting your proxy settings and see if this helps. A few related forum threads are here, here, and here.

Messages composed/sent using a Word/Outlook combination may cause problems. This forum topic suggests that it is caused by Microsoft creating abnormal "content-type" headers for image attachments.

EDIT

The headers in the message you posted are all loused up. Not only is the Content-Type all wrong and appears twice, but the file name has no extension which can be used to control the display.

You should really ask the sender to use a better email client, or maybe him just adding the extension '.png' to the file-name could solve the problem.

Maybe this article would help a bit : How to Edit Received Email Messages in Mozilla Thunderbird. If not, you could try Windows Mail / Outlook which, if it is anything like Internet Explorer, maybe analyzes the attachment by content rather than by MIME type.

share|improve this answer
    
Thanks for the detailed answer. It appears that the issue is the last you mention. Is there anyway around this? Thanks for your assistance. I updated question to reflect what I found. –  Lynda Sep 28 '11 at 2:43
    
See my edit above. –  harrymc Sep 28 '11 at 6:08
    
Thanks for the information, I have filed a support ticket with my CMS about this, we will see where it goes. –  Lynda Sep 28 '11 at 6:42
    
I tried to edit the source and it displayed an image but below the email not in the email! Go figure => –  Lynda Sep 28 '11 at 7:00
    
This is because the 'Content-Disposition: attachment' should be 'Content-Disposition: inline'. There could also be other errors, as the message headers are really thoroughly mangled. –  harrymc Sep 28 '11 at 7:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.