Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When i boot my PC, i get this in my Fedora 16 distro. I have tried as following but none allowing me to boot anymore. Any help please? I am blocked completely.

Grub loading. 
Welcome to GRUB! 
error: file not found. Entering rescue mode... 

grub rescue>
grub rescue> ls
(hd0) (hd0,gpt3) (hd0,gpt2) (hd0,gpt1)
grub rescue> ls (hd0,gpt2)/
./ ../ lost+found/ memtest86+-4.20 grub2/ System.map-3.1.0-0.rc3.git0.0.fc16.i686 config 3.1.0.0.rc3.git0.0.fc16.i686 grub/ vmlinuz-3.1.0.0.rc3.git0.0.fc16.i686 elf-memtest86+-4.20 initramfs-3.1.0.0.rc3.git0.0.fc16.i686.img initramfs-3.1.0.0.rc4.git0.0.fc16.i686.img System.mpa-3.1.0.0.rc3.git0.0.fc16.i686 config-3.1.0.0.rc3.git0.0.fc16.i686 vmlinuz-3.1.0.0.rc3.git0.0.fc16.i686

grub rescue> set prefix=(hd0,gpt2)/boot/grub
grub rescue> set root=(hd0,gpt2)

grub rescue>insmod normal
error unknown filesystem. or sometimes "error: file not found."

grub rescue>normal
unknown command normal 
share|improve this question
    
fs damage maybe? Run fsck from Live CD –  billc.cn Sep 5 '11 at 22:15
    
@billc.cn: it was working, only not not working after changing the spinify theme to another theme. Not filesystem damage i am sure. –  YumYumYum Sep 5 '11 at 22:16
    
In this case I guess you just need to somehow boot into linux and reinstall Grub. I don't use Fedora, but maybe there's a rescue mode on the installation CD that can fix the boot loader? –  billc.cn Sep 5 '11 at 22:23

5 Answers 5

up vote 1 down vote accepted

It is a bug

I followed comment #26 instructions, a little different with LVM because you have to do a:

vgchange -ay to detect your LVM.

share|improve this answer

Before wasting time with fsck, you could try getting the commands right:

set prefix=(hd0,gpt2)/boot/grub

That is not the pathname, as the output of the immediately preceding command showed. The pathname is either (hd0,gpt2)/grub or (hd0,gpt2)/grub2, since those are the directories that actually exist on your volume. (Which of the two, you'll have to work out for yourself.) Indeed, since you've set root to that volume the prefix could be simply:

set prefix=/grub

When the tool says that it cannot find the file that you've named, try believing the error message and correcting the name.

share|improve this answer
  • type "ls" to view partitions. Mine listed things like: (hd0) (hd0,msdos6) (hd0,msdos5), etc
  • then type, say: "ls (hd0,msdos5)/" across all your partitions until you find a directory listing that contains your linux /boot directory
  • Once you find the partition, set the prefix like so: "set prefix=(hd0,msdos5)/boot/grub"
  • then enter: "set root=(hd0,msdos5)"
  • do "insmod normal"
  • do "insmod linux"
  • do a "ls /boot" to find out the name of the latest "vmlinuz-2.6.38-14" and the "initrd.img-2.6.38-14-generic" or whatever it ends up being
  • in my case, I did a "linux /boot/vmlinuz-2.6.38-14-generic root=/dev/sda5 ro", which was the latest vmlinuz version number in my directory listing
  • set the initrd with the same version as above. In my case, it is "initrd /boot/initrd.img-2.6.38-14-generic"
  • type "boot"

Your system should hopefully boot into linux at this point. You booted into linux, but these changes are not permanent. To make them permanent, go into the command prompt and enter the following command: "sudo grub-install /dev/sda"

("sda" being the disk that contains your Master Boot Record and your linux partition are).

More information about the process can be garnered here: https://help.ubuntu.com/community/Grub2#Command_Line_and_Rescue_Mode

share|improve this answer

For multiple boots using grub2, some people may be making the same mistake I did when installing or updating Fedora 19 on a drive different than the drive that Windows is installed on. I’ll admit that I’m guilty of not following the basic rule when updating software: “RTFM”. I’m sure everybody knows what that stands for.

In my case, I replaced Fedora 16 on two computers – one that also has Windows 7 and the other that has Windows 8. In both cases, I failed, during the installation process, to include the device where the bootloader was to be put (for me, this is /dev/sda in both computers, where Windows is stored on).

When you come to the “Installation Destination” dialog, you need to specify the device that Windows is stored as well as the device where Fedora 19 is to go if it is different than the Windows device. In my case, it’s /dev/sdb on both computers, where Fedora 16 resides, which will be replaced with Fedora 19. After you select the devices, you need to click “Full disk summary and bootloader …” at the bottom of the dialog just to make sure that the correct device is selected for the bootloader (dev/sda in my case).

You then need to do custom partitioning if you want to delete the old linux partitions and replace them with partitions for Fedora 19.

share|improve this answer

I am using Ubuntu 12.04 and whenever I tried to start up my system, it stopped at grub rescue and here's what I did to solve this problem:

  1. Power off the system and disconnect it from power
  2. Remove the hard disk drive and reconnect it again
  3. Screw it back and restart your system

This is what I have been doing because my system is fond of running into such error messages. It also works with the error "OPERATING SYSTEM NOT FOUND".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.