Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've noticed a bit of a performance issue with some WD RE4 drives I'm using under AMD's hardware RAID solution. First a bit of background:

  • Environment: Windows 7 home premium x64
  • HDD's: 3x 1TB WD Raid Edition 4 in a RAID 5 setup with 128 kbyte stripe (2TB usable space)
  • Testing Tool: HD Tune, process set to "High Priority"
  • Processor: AMD Phenom II x6 1100T
  • Ram: 16GB DDR3/1600mhz
  • Motherboard: MSI 970A-G45

The image below pretty much depicts the issue I'm having. Every test has the same thing, a period of similar length where the performance drops to a few megabytes a second. This can't be a TLER issue as the purpose of RE4's is to work around that.

Any help would be greatly appreciated.

enter image description here

share|improve this question
    
You might also want to look into WDIDLE3 and the head park times for your computer. It has nothing to do with this test (since the heads obviously aren't parked), but it's an issue you should consider with these new WD hard drives (I personally just disabled head parking on my desktop). –  Breakthrough Sep 6 '11 at 16:46
    
Thanks Breakthrough, I could only find it for the RE2-GP, is that still applicable for RE4? The only bit of information I could find is that this could be that I'm using onboard RAID versus installing a RAID card. Could the onboard RAID be causing this? –  Howard Sep 6 '11 at 17:28
    
yes, the tool works with those drives as well (I used it on my brand new Caviar Green EARS-model, it worked on my older Caviar Blacks as well - although head parking was disabled on those already). I doubt that using the onboard RAID is the issue here (assuming all driver/BIOS updates have been done), especially if it supports RAID-5 under hardware. –  Breakthrough Sep 6 '11 at 17:34
    
Another issue I run into, RAIDXpert's Sync/Fix option or media patrol never go beyond 0%. They do however put an interesting tidbit in the events log "Synchronization is requested to perform on the logical drive "RE4Array " that has never been initialized." which doesn't make sense. This coupled with random "Unknown event"'s that pop up occasionally, I have no clue what this RAID setup is doing. Unknown event's also occured for 2x Caviar Black's in a RAID 0 setup. –  Howard Sep 6 '11 at 17:40
1  
@Howard - could you please post the screenshots for the other three tabs? –  grs Oct 7 '12 at 4:50

1 Answer 1

Just to note that the AMD RAID solution in the SB950 is not a "hardware RAID" solution.

The message about the array not being initialised would indicate that the array is initialized in background, there is nothing intrinsically wrong with this, but performance should improve when initialisation has completed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.