Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I suddenly could not RDP into my server after rebooting it. Turned out the Firewall was blocking me, I remotely shut off the firewall service (parallels virtuozzo panel) and was able to RDP in. When I went to add my office IP to the firewall to allow me to connect, it won't launch the control panel unless I enable the Windows Firewall. If I do that, it kicks me off of RDP naturally. So how on earth can I configure this thing?

(cross-posted from Serverfault)

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

Use netsh – all settings are under the firewall context.

  • To quickly open RDP, run netsh fire add port TCP 3389 "Remote Desktop"
  • To manage other settings, run netsh, enter firewall, and use ? to list commands.

You can also edit the settings on Registry directly (regedit), under HKLM\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy. (This even works over the network, assuming Remote Registry is running.)

  • For Remote Desktop, under the key StandardProfile\GloballyOpenPorts\List add a string value named 3389:TCP with the data 3389:TCP:*:Enabled:Remote Desktop.
share|improve this answer
    
Registry edit for the win, thank you kindly! –  ioSamurai Sep 6 '11 at 18:11
add comment

Take a look at the Local Security policy Admin tool. There is a section for Windows firewall.

enter image description here

share|improve this answer
    
Is it that? (see edit to your answer) I don't see it.. –  ioSamurai Sep 6 '11 at 18:08
    
Ok, the registry edit worked from chosen answer. –  ioSamurai Sep 6 '11 at 18:13
    
"IP Security Policies" refers to IPsec, not the firewall. –  grawity Sep 6 '11 at 21:29
add comment

You should be able to make settings changes in the Group Policy Editor without the service running.

GPEdit.msc -> Local Computer Policy -> Computer Configuration -> Windows Settings -> Security Settings -> IP Security Policies.

share|improve this answer
    
"IP Security Policies" refers to IPsec, not the firewall. –  grawity Sep 6 '11 at 17:56
    
Thanks for the clarification. –  music2myear Sep 6 '11 at 17:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.