Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have successfully installed PHP5.3 but cannot seem to get it to work on IIS7. I have followed the tutorial on iis.net (http://learn.iis.net/page.aspx/246/using-fastcgi-to-host-php-applications-on-iis-70/) and can clearly see in the IIS Console that the mapping for *.php files should execute php-cgi.exe as a Fast CGI module. However, when I try to load a php page in my browser, I see no output. Any suggestions on how to debug this?

share|improve this question
    
Running IIS7, Windows Vista Home Premium x64, PHP5.3 NTS x86 via FastCGI ... I now realize I probably need the x64 version of PHP5.3, but cannot seem to find a build for it on the php download site. –  Brian Sep 1 '09 at 1:11

1 Answer 1

up vote 1 down vote accepted

There is a forum post over at iis.net where wendac give instructions on how he got your same situation to work: Vista x64, IIS 7 and PHP 5.

I would think that the most important step that you might be missing is step 6:

6) Right click on the Application Pool that you want to run PHP on and select “Advanced Settings…” or select the same from the Actions pane after selecting the Application pool

Change the “Enable 32-bit Applications” to True (if you want the application pool to spawn in a 32-bit mode)

Click OK

share|improve this answer
    
While that did not initially work, I uninstalled PHP and removed the IIS settings completely. Then enabled 32-bit applications and installed PHP 5.3 x86 and let it configure IIS to run it as a FastCGI module and it worked perfectly! Thanks for the tip. –  Brian Sep 1 '09 at 15:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.