Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

It's very disturbing when making a Kiosk application, every time the lock screen and screensaver shows up, also many popup + battery or updates shows up.

Where and how can I completely disable the lock screen, screen saver and alerts via a configuration file or from the terminal?

I have the tried following but nothing works:

  1. failed

    vim /etc/default/acpi-support
    ;LOCK_SCREEN=true
    
  2. failed

    $ gconftool-2 --type boolean -s /apps/gnome-power-manager/lock/suspend false
    $ gconftool-2 --type boolean -s /apps/gnome-power-manager/lock/blank_screen false
    $ gconftool-2 --type boolean -s /apps/gnome-power-manager/lock/hibernate false
    $ sudo init 6
    
  3. failed (but worked for disabling the lock prompt)

    gconftool --set --type=bool /apps/gnome-screensaver/idle_activation_enabled False
    gconftool --unset /apps/gnome-screensaver/themes
    
  4. failed: To make it permanent:

sudo service gdm stop sudo X -configure vim /home/[username]/xorg.conf.new

Section "Screen" Identifier "Screen0" Device "Card0" Monitor "Monitor0" DPMS "false" <<<<<<<<< Added this line SubSection "Display" Viewport 0 0 Depth 1 EndSubSection SubSection "Display" Viewport 0 0 Depth 4 EndSubSection SubSection "Display" Viewport 0 0 Depth 8 EndSubSection SubSection "Display" Viewport 0 0 Depth 15 EndSubSection SubSection "Display" Viewport 0 0 Depth 16 EndSubSection SubSection "Display" Viewport 0 0 Depth 24 EndSubSection EndSection

I tried the following suggested command from the Ubuntu forum but the whole system froze:

sudo pm-suspend

Follow up: http://askubuntu.com/questions/37761/xorg-conf-in-ubuntu-natty-11-04

http://www.x.org/releases/current/doc/man/man5/xorg.conf.5.xhtml

share|improve this question
    
Dumb question, but can you confirm that you don't want the simple GUI answer, or that they don't work for some reason? –  Dennis Sep 7 '11 at 13:02
    
@Dennis: not with GUI. –  YumYumYum Sep 7 '11 at 13:04
1  
Once again, no help but... did you also post on askubuntu.com the stack exchange site dedicated to Ubuntu? For example this one approaches what you are asking askubuntu.com/questions/27435/… –  Dennis Sep 7 '11 at 14:03
    
@Dennis: I tried that example, still not working what i am trying. But after waiting 5 / 6 minutes as idle, it still turn off my monitor. And when i press enter it (does not show now lock prompt). –  YumYumYum Sep 7 '11 at 14:51
    
I want system do not turn of my monitor, nor it put that lock screen, nor screen saver, nothing. Just leave it as it is when you are working. How can i do that? –  YumYumYum Sep 7 '11 at 14:52

2 Answers 2

up vote 1 down vote accepted

After getting the screensaver turned off I found that it was the power manager that kept putting the screen to sleep. For me the following worked xset -dpms which I found at http://v2kblog.blogspot.com/2008/08/disabling-monitor-power-saver.html and it included steps to set it up permanently.

share|improve this answer
    
Thanks. In the terminal/or via ssh i can do this to play with and works. e.g: 1. Turn off: export DISPLAY=:0.0 && xset dpms force off 2. Turn on: export DISPLAY=:0.0 && xset -dpms. –  YumYumYum Sep 8 '11 at 21:13

Disabling the lock seemed to work for me on Ubuntu 14.04

DISPLAY=:0 sudo gsettings set org.gnome.desktop.screensaver lock-enabled false
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.