Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a long standing issue with remote assistance between a home and work PC. My wife and I both use MSN messenger and I used to be able to control her PC at home via MSN Remote Assistance. Some time ago however this stopped working and I don't know why.

We're both running the latest versions of MSN Live Messenger and I've checked the appropriate firewall ports are open, but it still doesn't work and MSN just says something useless like "The person isn't responding".

Any suggestions for how can I diagnose this?


More info: I just tried direct Remote Desktop between work PC and home PC and it works fine - so I presume all the appropriate ports are open. Just Remote Assistance doesn't work.

I'd like to get RA working so I can demonstrate how to do things remotely. With Remote Desktop the person at the other end gets booted off and can't see. With Remote Assistance they can follow along step by step.

Some comments below suggest using other solutions, which is fine and do work, but there must be a way to diagnose RA and get it working.


The person you are trying to help isn't responding


Experimenting with this some more, the notebook that I was using at work today that refused to connect works fine for remote assistance when I bring it home. So I guess this must be a problem with our network configuration at work. I've checked that 3389 is open on firewall on office router and remote desktop works both ways.... just not remote assistance.

I've read that remote assitance won't work if client and server are both behind Non-UPnP/NAT routers. If one has UPnP it's supposed to work. Office router doesn't have UPnP enabled but my home one does.

I've also scoured the event logs on both ends, nothing noteworthy - unless I'm looking in the wrong spot).


Note (copied from comment): I've just tried ShowMyPC which is based on VNC and it works, but I'd still like to figure out what's wrong with RA - it's just bugging me.

The question is only about Remote Assistance, no need to propose solutions based on other programs.[/edit by Gnoupi]

share|improve this question
2  
Let me connect via remote assistance and I'll fix it for you. :-) –  hanleyp Sep 1 '09 at 1:53

6 Answers 6

I use TeamViewer to give "tech support" to my friends and family all the with, and it works. You don't have to configure anything on either ends and, in my experience, it even works through corporate and school firewalls and proxies. Using it is as simple as opening the .exe file.

It is available from the TeamViewer website. There is also a portable version available.

share|improve this answer

Check if the Network was set as "Public" for some reason.
In that case the firewall exception for Remote Assistance is turned off.

If that's not the problem, I would in any case turn off all firewalls and test again.

share|improve this answer

Ignoring the obvious security concerns that your current setup has, an issue like this is tough to track down. Since traffic has to pass multiple routers and switches to move from your home to your work machines, the best way to troubleshoot is to simplify the connections. her's what I would test in order:

1) Two machines on the same network. - I see you already did this.

2) Two machines separated by your router. This is a little trickier, You's need to put a computer between your router and the internet. The easiest way to do this is to grab another router to and plug your second machine and your current router into it. This tests the home perimeter firewall that is on the router.

3) Two machines at different locations on the same ISP. Ask a friend or neighbor, preferably one with the same service provider if you can connect a computer directly to their modem (bypassing the need to change their router). This makes sure that your modem or the ISP's internal network is not preventing this.

If the above all works, then one of two things are going on. Either your work network doesn't work right, or the ISP is blocking that kind of traffic. I have heard that many ISP's are blocking various ports "for your own protection". There really isn't anything you can do in that case, they control the bits and can do with it what they want.

With all that being said, I would look into getting a VPN router. This is generally a much better way to connect to a network since you have to use a username and password to gain access to the internal network. In this setup, anyone in the world can attempt to brute force a remote desktop session. There are also a lot of issues with uPnP that can open you up to attack. A VPN would bypass the need to open ports and virtually put your machine on the same network as your home PC. That logically changes the connection to something that you know works.

Hope this helps.

share|improve this answer

EDIT: Given you are establishing the connection using MSN I guess my answer does not apply.

Excuse me if this is too obvious but just to be sure: does the resulting invitation file include your public IP or the inner/private one? When you create the invitation on a PC that is behind a router usually the RCTICKET attribute contains the inner IP together with some weird port number.

RCTICKET="65538,1,192.168.1.102:49201...

Especially the inner IP is useless behind a router. I'm not sure what to think about the port number, might be worth playing with that a bit. (At the very moment I can't test it unfortunately.)

I'm experiencing the same issue you described (worked before, does not now) and this has been one pitfall I've noted.

share|improve this answer

In the System Properties (Win + Pause) there is a remote tab. Ensure that her PC is allowed to be controlled remotely:

alt text

share|improve this answer
    
Yep, I've checked that and it's on. –  cantabilesoftware Sep 1 '09 at 4:04
    
could you provide me with a screenshot of the exact error? I'll do some hunting for ya. –  John T Sep 1 '09 at 4:11
    
Hi John, thanks for your offer to help. So I just tried it again and this time I get nothing, no error at all. The exact text of the message I was getting before was "the person you are trying to help isn't responding". I checked with my wife, she saw nothing on her screen that suggested she was supposed to do anything. If I can get a screen shot I'll post it later. Very frustrating that there's no way to diagnose this. –  cantabilesoftware Sep 1 '09 at 6:13
    
That's fairly odd. Has the network undergone any changes recently (hardware, software) ? I saw that you mentioned checking the firewall, did you check it on both machines ? Perhaps autotuning has somehow been enabled. Try entering this into command prompt: netsh interface tcp set global autotuninglevel=disabled –  John T Sep 1 '09 at 6:23
    
I've attached a screenshot and some more information to my original post. I've also tried the netsh command, still no go. –  cantabilesoftware Sep 1 '09 at 12:47

Try using VNC?

Software that hides it's working from the user to make it "easy" is notoriously hard to debug when something goes wrong. VNC will give you the same functionality, and also throw some useful messages when it doesn't work.

share|improve this answer
    
I've just tried ShowMyPC which is based on VNC and it works, but I'd still like to figure out what's wrong with RA - it's just bugging me. –  cantabilesoftware Sep 1 '09 at 3:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.