Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm a developer building silverlight apps and using Server 2008 R2 as my main operating system. I have Hyper-V running on the machine that I use to host my test O/S's and and OS for non-dev stuff (word /outlook etc). I pretty much need dual screens for my work but I have hit problems in finding a graphics card that doesn't cause a blue screen on Server 2008. The two cards I have tried so far are: NVidia Quadro ATI FirePro 2270

both caused blue screens a couple of times per day. If I take the graphics card out and use the motherboard VGA output I get a rock solid stable system (but then I am restricted to one screen).

I should say that for both graphics cards I used the Windows 7 drivers, because they don't give the option of WS 2008 drivers! I know that might be the problem but I can't find a graphics card that does offer WS 2008 drivers!

Can someone please recommend me a graphics card that runs WS 2008 R2 with Hyper-V.

p.s. I have installed all service packs, updates and I'm running the latest releases of the graphics drivers.

share|improve this question

migrated from serverfault.com Sep 7 '11 at 17:52

This question came from our site for system and network administrators.

    
Any details on the bluescreen? Might be a problem with the MB or chipset, basically unrelated to the video card. – Chris S Sep 7 '11 at 18:13

I pretty much need dual screens for my work but I have hit problems in finding a graphics card that doesn't cause a blue screen on Server 2008.

Go to a shop. Buy a 100 USD ATI card. Install drivers. Finished.

I should say that for both graphics cards I used the Windows 7 drivers, because they don't give the option of WS 2008 drivers! I know that might be the problem but I can't find a graphics card that does offer WS 2008 drivers!

And you are painfully unaware of teh fact (as developer) 2008 R2 and Windows 7 have identical kernels ;) And thus the same driver model.

share|improve this answer
    
I already have bought the 100USD ATI card - the FirePro 2270 but still no joy. – Calanus Sep 2 '11 at 7:45
    
Ah, no. I waqs thinking of a normal card, not a firero series. I have no problems with ATI based cards anywhere use them (and that includes some servers). Maybe your card just sucks (as in: broken). Get a replacement by warranty or try it out in another computer. – TomTom Sep 2 '11 at 8:37

Do you have SP1 for Win2k8 R2 installed? If not definitely install it; I had to have it for my dev setup to work correctly on my laptop w/ NVIDIA Quadro NVS to work correctly.

Regardless, to see if it's actually hyper-v causing the issues, you can create a "no hypervisor" boot entry that will disable hyper-v.

Also, see this Microsoft connect submission that has a lot of details (and a hotfix) with regard to hyper-v and blue screens in the comments.

share|improve this answer
    
I do have the SP1 installed - I realise that the presp1 version has a lot of hyper-v / graphics issues – Calanus Sep 27 '11 at 14:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .