Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows 7 Home Premium on my machine and want to install Windows XP as well.

When I run through the Windows XP installation, it copies all the required files and restarts - I then get an NTLDR is missing error and can't do anything.

I'm able to repair the system using the Windows 7 repair CD and it works again, but I can't install Windows XP.

I think the problem is that my hard drive is in SATA mode in the BIOS settings and Windows XP should install on IDE mode. Is this correct? If so, how can I change from SATA mode to IDE mode?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

You can change this option in the BIOS (or EFI) of your machine. I have seen this a few times and assuming there is nothing else on your machine interfering/incompatible with XP, this should work.

That being said, if you have a USB floppy drive or similar, you may be able to find the drivers on your motherboard manufacturers website in order to download the drivers and install them on the XP machine. Alternatively, if you don't mind getting a little dirty / making your own XP disk, you may be able to put these drivers in there.

share|improve this answer
    
+1. The BIOS change is the quickest and dirtiest way to handle this in my experience. –  user3463 Sep 7 '11 at 22:28
    
Wait, would Windows 7 still successfully boot after that, without changing back to SATA mode? I never tried this, instead always find the SATA driver for XP because I thought 7 won't boot afterwards –  Martheen Cahya Paulo Sep 8 '11 at 0:40
1  
@Martheen Cahya Paulo - Honestly, I missed the "too" part, thought it was a change to Windows XP. Honestly, you are correct if it was installed that way - reinstalling under SATA would work, or changing the option back each time. You are right however, finding the correct driver for XP is by far the best way as this can lead to increased performance. –  William Hilsum Sep 8 '11 at 1:52

I would recommend try everything William said, but if it comes down to changing BIOS settings, this is a procedure to keep AHCI:

  1. Turn off AHCI / turn on IDE compatible mode in BIOS
  2. Install XP
  3. Get your chipset's driver package and extract the AHCI driver from it
  4. Force an "upgrade" of your disk controller driver and select the AHCI for it.
  5. Reboot and turn on AHCI before booting into XP again.

Now you should have AHCI drivers in both OSes.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.