Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every time I launch Firefox and go visiting some websites, I notice it freezes for about 10 seconds. Not always in the same websites, but it always happens sometime in the first 2 or 3 minutes of running. I can see the hard disk led is ON all the time the browser is hung.

My operating system is Linux and I don't currently have any extension/plugin installed here.

I have no form completion, no history and have no more than 20-30 bookmarks.

Has somebody noticed something similar, or know how can I debug this to find out what Firefox is doing or trying to do?

share|improve this question
    
Disable the Flash plugin if it's there and see if it continues. –  user3463 Sep 7 '11 at 21:50
    
No flash/other plugins installed –  user683887 Sep 7 '11 at 21:52
    
possibly related: superuser.com/q/82492/494 –  sblair Sep 7 '11 at 21:56
    
I tried deleting my mozilla directory but the problem remains. I've updated the question to state I set firefox not to save form data nor browsing history, so I think databases should not a problem here? –  user683887 Sep 7 '11 at 22:06
1  
It's probably loading/compiling some problematic add-on (double check because you can't normally have none) or is trying to read a large sqlite file/journal. In either case, try using a new profile. Under Linux, the profile directory is under ~/.mozilla. –  billc.cn Sep 7 '11 at 23:05

2 Answers 2

Make sure you have the relevant debug packages if any. Try running strace firefox and also running it in gdb and producing a backtrace after the freezing stops (you can google for info on how to produce a backtrace with gdb). Both will likely slow down firefox but will give quite a bit of useful info. You can post them on pastebin and link here, but it might also be prudent to submit a bug report to mozilla or your distro.

share|improve this answer

I had the same problem on Win XP SP3. After updating from FF 3.6 to FF 11, I noticed that FF would freeze for about 20 seconds on startup. Hard drive LED light is lit up solid. This freezing continued with FF 12 and FF 13.

Cause: The cause was the old versions of urlclassifier.sqlite from previous FF versions, going back to FF 2.
For some reason, FF was reading and compiling all of those old files upon startup.

Solution: Log on as an administrator and delete all urlclassifier variants ('urlclassifier.sqlite', 'urlclassifier2.sqlite', 'urlclassifier3.sqlite') from all of your FF profiles.
In Win XP, search the Documents and Settings folder for all files beginning with "urlclassifier", example: urlclassifier*.*
Delete all that you find. FF will rebuild just the urlclassifier3.sqlite on the next startup.

Result: After I deleted and allowed FF to re-download only the urlclassifier file that it needs, the freezing disappeared.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.