Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can not mount my NTFS disk read-write. I tried ntfsMounter as well as this command:

$ sudo mount_ntfs -o rw /dev/disk1s1 foo

But they mount as read only:

$ sudo mount
/dev/disk1s1 on /Users/foo/bar (ntfs, local, read-only, noowners)

The weird part is that it worked some time ago. But then it just stopped working. I've even tried to format the disk again with no result...

I also have a friend with the exact same disk and mounting that will result in both read and write access.

Is there some weird cache I can release or something?

share|improve this question

migrated from stackoverflow.com Sep 7 '11 at 22:08

This question came from our site for professional and enthusiast programmers.

    
Nobody seems to have directly addressed this in their answers so I'll add it here: Mac OS X does not ship with a read/write NTFS driver. The one bundled is read-only, so what you're experiencing is normal. As both answers say, you can install another NTFS driver that does support read and write. –  Scott Sep 8 '11 at 6:20

2 Answers 2

Try using NTFS-3G. It's a free open-source engine to read and write NTFS drives. Once it's installed, you can mount just by connecting the drive to the computer, and NTFS-3G will take over

share|improve this answer

Note that Tuxera started charging the binary distribution of the latest ntfs-3g. The older version on their blog is not compatible with 64-bit kernel or Lion. (You can install it, but it won't mount anything.)

You can however, compile it from source. It's all packed up for you, so all you have to do is to install Xcode 4 and copy and paste 3 commands.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.