Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I tried installing/upgrading my HP Compaq (fully sufficient specs) running Vista Home Edition to Windows 7.

I continuously get the error for upgrade that No disk space is available and if I try a fresh install (x64/x86) then I get No hard drive found.

At first it had an OEM partition, so I used easeUS to merge the partition to the C:/ drive, yet still got the problem (bear in mind I have 110gb free). So then I tried splitting into two partitions, one half having 110gb (20 free) and the over 90gb. However I still get the same problem, no matter what I try.

I think this may be quite an old version of W7..

share|improve this question
Are you using the same disk for upgrade/fresh? Sort of scary about no hard drive found if this is the same disk. – William Hilsum Sep 8 '11 at 12:24
planning on dualbooting or just 7? – Journeyman Geek Sep 8 '11 at 12:27
Just windows 7 install ... using the same disk. It's definitely there, the OS see's it, hardware manager see's it, I havent checked the bios yet but easeUS saw it as well.. – rickyduck Sep 8 '11 at 12:28

This sounds like an issue with your partition table. Try burning GPartEd to a CD, then boot the computer to it. It will bring up a GUI. Delete the partitions (WARNING, THIS WILL DELETE ALL DATA FROM THE DRIVE Only advanced recovery software will be able to get your data back from this state, if at all.). Then try installing Windows 7 again. It will see it as a blank drive and shouldn't have any issues.

share|improve this answer

You're probably going to have to use the manufacturer's recovery CD to recover your OS... or slipstream the drivers for your disk controller directly into your windows 7 install disk. You might be able to get lucky and go into the bios and change your disk controller "mode" to emulate a different mode which will let you install 7... and then after getting the proper drivers installed... switch it back.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .