Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

According to this page : http://docs.info.apple.com/article.html?path=Mac/10.5/en/cdb_sptfky.html
the keyboard shortcut to open the Spotlight menu in OS X is CMD-Space Bar.

However, I am using a japanese macbook pro. When I press CMD-Space Bar, the language input mode changes (switching between latin characters, japanese hiragana, japanese katakana).

How can I set the shortcut CMD-Space Bar to open the Spotlight menu ?

share|improve this question
add comment

3 Answers 3

In System Preferences > Keyboard, select Keyboard and Text Input on the left and un-check Select previous input source on the right.

You may also want to uncheck the Select next source in Input menu item to enable ⌘⌥ Space (Command-Option-Space) as the Spotlight-in-Finder shortcut.

share|improve this answer
    
Sorry CajunLuke, but unchecking this settings does not focus the Spotlight search menu. Instead, at best nothing happens, and from Finder a window opens with the message "No Items Selected". –  wil Oct 9 '11 at 5:55
add comment
up vote 0 down vote accepted

I found the keyboard shortcut that actually activates the Spotlight search bar on my computer. It was CTRL+Spacebar.

share|improve this answer
add comment

Go to System Preferences → Input Sources → Keyboard → Spotlight → Check the spotlight menu keyboard shortcut → Double click the existing shortcut (cmd + space) → Change it to the shortcut key you prefer

For language switch, I use cmd + Space For spotlight, I use Ctrl + Space

Source

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.