Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Trying to access admin$ share on remote machine, I get this error:

Multiple connections to a server or shared resource by the same user, using more than one user name, are not allowed. Disconnect all previous connections to the server or shared resource and try again.

However, net use reports no entries:

C:\Users\XXXX>net use
New connections will be remembered.

There are no entries in the list.

Can it be that admin$ doesn't exists on remote machine?

share|improve this question
    
Have you tried rebooting the remote machine? –  jftuga Sep 8 '11 at 18:39
    
@jftuga: I think it is "Have you tried turning it off and on again?" –  grawity Sep 8 '11 at 20:33

1 Answer 1

up vote 2 down vote accepted

If a share does not exist, the server would return "Network name not found". What you are getting now means exactly that: there is another active connection.

It seems that net use only reports explicitly opened connections (net use \\server\share or mapped drives through GUI), but not implicit ones (established by simply opening a file or pipe). Use netstat to see if there are any active SMB connections, and check with Process Explorer for processes that hold open handles to files on network shares.

share|improve this answer
    
I tried TCPView and you are right, it has a connection established. The remote port is 445 (NetBios I think) and the process is System, so I can't close it. How to close a NetBios connection without net use * /d? –  Veehmot Sep 8 '11 at 20:20
    
@Veehmot: Close any open files that are using the connection, and it will (should) go away within seconds. Again, Process Explorer's search function should help. –  grawity Sep 8 '11 at 20:32
    
Nevermind, I used Right Click -> Close Connection and it works fine now. Thanks! –  Veehmot Sep 8 '11 at 20:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.