Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to stop Quicktime from handling TIFF files without uninstalling Quicktime or disabling the plugin.

I have Cannon iR3045 scanner/fax/printer/copier. When you scan documents, they are available via the web interface as TIFF files. When I view the scan, Quicktime is loaded. Unfortunately Quicktime blocks saving the image unless you pay. I think it would generally be more useful to have no support for viewing tiff files in the browser then to have Quicktime open the file, and block users from being able to save the file.

The challenge is that Quicktime must be installed on the computers for access to video on other pages, so I cannot uninstall quicklime, or disable the NPAPI plugin.

The browser primarily being used is Firefox 5 or 6, but I have see the same behavior on Chrome. The systems in question are mostly running Windows 7.

I have checked the Control Panel\All Control Panel Items\Default Programs\Set Associations. Quicktime is not set to handle .tiff or .tif files, that is currently set to Windows Photo Viewer.

If I disable the NPAPI plugin Quicktime in Firefox/Chrome then the browser does prompt you to save the tiff file which is what I want.

So is there any way for me to disable Quicktime handling of just Tiff Files?

share|improve this question

2 Answers 2

Have you checked in Firefox the handling of "QuickTime Image" ?
Chrome might have an equivalent setting somewhere, but I am not a user.

This is found in Tools / Options / Applications :

image

share|improve this answer
    
That appears to work on Firefox. Still need to figure out how do that in Chrome. –  Zoredache Sep 15 '11 at 3:28
    
For Chrome, you could try to open chrome://plugins/ and disable all or some of the quicktime ones (there should be about 7 of them). –  harrymc Sep 15 '11 at 6:39
    
Yes, I know that is an option. I even mentioned it in the question. But the person I am trying to help needs to be able to use Quicktime for a video on a web site. AFAIK the plugins offers no granularity. I cannot disable the Quicktime handling of tiff only. You only have the choice of Quicktime or no Quicktime. –  Zoredache Sep 15 '11 at 6:48
    
Is using Firefox instead of Chrome an option ? –  harrymc Sep 15 '11 at 7:18
    
It is an option, I did upvote your answer. I didn't mean to imply that your answer was bad in any way. I just added the comment to indicate to anyone else wthat I still some hope that someone could come up with a system wide fix so it applies to all browsers, or perhaps someone could suggest a fix for each browser. –  Zoredache Sep 15 '11 at 7:25

Go to chrome:plugins and click + Details in the upper right corner.

There, you have the ability to disable Quicktime as the handler (npqtplugin7.dll) for image types including tiff and jpeg. It was the last of the Quicktime group for me. This will leave the other six Quicktime handlers on.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.